Should I update safari

Discussion in 'Mac Basics and Help' started by lala1886, Jun 12, 2010.

  1. lala1886 macrumors newbie

    Joined:
    Mar 24, 2010
    #1
    The mac version I am using is os x 10.5.5 and currently using the safari 3.1.2. I wanted to update because my safari can't play YouTube videos :( (I can only watch in Fire Fox.)

    This is the link I found but my mac is 10.5.5 so it's below the requirement.

    http://www.apple.com/safari/download/

    Is it because of my mac isn't update enough? Cos I always ignore updates. Can I ignore software updates? (((Every time, when I switch on my mac, a window (see attachment) appears on the desktop.)))
     

    Attached Files:

  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    :confused: you shouldnt really ignore software updates, they patch security and stability issues.

    open Software Update and install all updates up to 10.5.8 and just install that trackpad firmware (if its genuine? im not sure looks a bit fishy, but someone can confirm).
     
  3. serega macrumors regular

    Joined:
    Nov 19, 2007
    Location:
    Seattle
    #3
    I updated both Mac and PC to Safary 5 and now neither of them show my messages in my favorite social network odnoklassniki.ru (in russian). I believe it could be related to a new "reader" that built in Safary 5. I downloaded and installed Firefox and every thing working fine now. Hope apple will fix it.
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    I just read that Safari 5 requires 10.5.8 or higher. It was in a post, not from Apple.
     
  5. johannnn macrumors 65816

    johannnn

    Joined:
    Nov 20, 2009
    Location:
    Sweden
    #5
    Why do you ignore all the software updates??? They are meant to improve your computer experience
     
  6. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #6
    Yes you should upgrade Safari. Yes you should upgrade your OS to 10.5.8.

    But absolutely, most importantly, before you upgrade.... Do a back up first, and confirm that the back up works.

    There is something you need to know. The Computer Gods and Goddesses are on summer holidays, and left the immature Goddlings in charge. Your situation is exactly the one they like to take advantage of. You ask a simple question. We tell you to upgrade, and don't worry it will make your computing experience better. You ask "Are we sure?" And we answer "Yep, we're sure. Completely safe. Trust Us!!" You upgrade and discover a previously unknown bug, so the upgrade trashes your system. You come back to the forum and tell us how our advice totally messed up your life, you hate Apple, and are buying a Dell with XP. We tell you to restore from your back up. You claim that we never told you to back up first. We tell you that it is common practice, and any noob should have known to back up first. You get all unhappy that you were called a noob, and call us idiots....

    And then things get ugly....

    So back up first, and we can all stay friends :D
     
  7. lala1886 thread starter macrumors newbie

    Joined:
    Mar 24, 2010
    #7
    ok so I have updated and no more of that "update window" when I log in to my mac.

    I checked the "Software Update" in the apple menu bar and there is another update (see attachment) left so I clicked 'install' and the computer restarted but frozen when installing :(
     

    Attached Files:

  8. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #8
    You may have better luck with the 10.5.8 Combo Updater directly from the Apple downloads site.
     
  9. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #10
    The second one is for Mac OSX Server. I'm guessing you don't want that one.
     

Share This Page