Should I upgrade to ios5 or wait for the jailbreak?

Discussion in 'Jailbreaks and iOS Hacks' started by jayeskreezy, Oct 14, 2011.

  1. jayeskreezy macrumors 65816

    Joined:
    Mar 3, 2005
    #1
    I have an iPhone 4 that has 4.3.5 installed and the firmware of 4.10.01. Does it matter if I upgrade to ios5 now or should I wait for the ios5 jailbreak?

    Will I be able to jailbreak if I upgrade to iOS5 now?
     
  2. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #2
    it's up to you I'm waiting but I'm 4.3.3 untethered jb

    as far as can you jb 5.0 yes Redsn0w! tethered!
     
  3. jayeskreezy thread starter macrumors 65816

    Joined:
    Mar 3, 2005
    #3
    Thanks. I guess I was asking if I upgrade now to iOS 5 will that affect my ability to do an untethered jailbreak later? I don't do tethered jailbreaks. It's pointless to me.
     
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #4


    4.3.5 and 5.0 are both tethered jailbreaks right now latter on it should be untethered. might be a week or several nobody knows when the untethered version will be out. or if you will have to rejailbreak the device or just run it over it. lots of stuff not supported yet in cydia for 5.0 so i'd wait. but others can't resist the new shinny IOS!
     
  5. Trauma1 macrumors 6502a

    Joined:
    Jun 15, 2009
    #5
    The only reason to wait would be if you wanted to preserve your baseband, but since you're past 01.59.00 it doesn't matter.

    You can always use TinyUmbrella and preserve your SHSH blobs in case you decide to downgrade.
     
  6. atifhasan86 macrumors newbie

    Joined:
    Aug 20, 2008
    #6
    you cant save the shsh blobs if you upgrade to ios5, meaning you wont be able to downgrade later. its either ios5 or ios5 :)
    http://itechvision.blogspot.com/2011/10/shsh-blobs-for-ios-cant-be-saved.html
     
  7. Trauma1 macrumors 6502a

    Joined:
    Jun 15, 2009
    #7
  8. P!kN!mO macrumors member

    P!kN!mO

    Joined:
    Aug 14, 2011
    #8
    wait tell most of the JB appz(tweaks) updated for iOS5 compatibility:
     
  9. kawasakirider macrumors regular

    Joined:
    Oct 15, 2010
    #9
    I was jailbroken until iOS5 came out. I really enjoy iOS 5, and I am glad I updated, but I will be jailbreaking as soon as I can. It's not a life changing issue for me, like many on here make it out to be.
     
  10. jayeskreezy thread starter macrumors 65816

    Joined:
    Mar 3, 2005
    #10
    Thanks for the input everyone. I guess I'll just wait until ios 5 is less buggy. I've been hearing about quite a few issues with it.
     
  11. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #11
  12. Spectrum Abuser macrumors 65816

    Spectrum Abuser

    Joined:
    Aug 27, 2011
    #12
    There really is no valid argument against upgrading to iOS 5. I have blobs saved for both 4.2.1 and 4.3.3 so if I really wanted to I could downgrade and have an un-tethered jailbreak. But iOS 5 is a big performance improvement compared to the iOS 4 days so I'm staying.
     
  13. nyfliiboy macrumors regular

    Joined:
    Jun 15, 2010
    #13
    iOS5 > being jailbroken on 4.whatever. I upgraded today and absolutely love every feature. I can go without my jailbroken apps for a week or two. When i was jailbroken on 4.3.3 my springboard would constantly crash and my phone would always freeze. My iphone is running flawlessly on ios5
     

Share This Page