"Show caller ID" setting gone?

Discussion in 'iOS 9' started by sieeegel, Sep 15, 2015.

  1. sieeegel macrumors newbie

    Joined:
    Jul 30, 2008
    #1
    i have been trying to find a way to block my number on other devices when I call. Under ios8 and younger it was under settings/phone/show caller ID. Can't seem to find that setting to switch on and off on ios9 beta. Any idea where it is? I need this for work as I don't want clients to see my number. Thanks
     
  2. skyhawkmatthew macrumors member

    skyhawkmatthew

    Joined:
    Oct 1, 2007
    Location:
    Australia
  3. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #3
    Still there for me too.

    Side note it's controlled by carrier updates. Maybe they have removed it but I doubt that. A reset of your network settings should bring it back if it's a glitch.
     
  4. Speedman100 macrumors 6502

    Speedman100

    Joined:
    Jul 21, 2013
    Location:
    Michigan, USA
    #4
    I have never seen that feature. And I still don't see it. I guess Verizon doesn't offer that.
     
  5. Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #5
    carrier dependent. use *67? that blocks caller id in canada, for a small charge i think or maybe its free now. dont know if thats a canada thing or worldwide
     
  6. gordon1234 macrumors 6502a

    Joined:
    Jun 23, 2010
    #6
    I don't know the details of your situation at all, but you might want to look at alternative ways of hiding your phone number. I know when I had my own business, I used to use a Google Voice number for business calls. The problem with blocked numbers is that people don't like receiving calls from them and often won't answer. I never answer a blocked number, nor does my girlfriend, parents, or most other people I know. Usually it's scammers or spammers or something else unpleasant. It also prevents your clients from creating a contact entry for you.
     
  7. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #7
    I'm on Rogers in Canada and I have the option to block my caller ID. This is on 9.1 beta 1 though, but I'm pretty sure the option has always been there for me.
     

    Attached Files:

  8. Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #8
    it has for me as well, also on rogers
     
  9. SoYoung macrumors 6502

    Joined:
    Jul 3, 2015
    #9
    This option was always and its still there for me as well and I'm with Telus in Canada.
     

Share This Page