"Show file extension" for multiple files

Discussion in 'OS X Mavericks (10.9)' started by macstatic, Jun 8, 2015.

  1. macstatic macrumors 6502a

    Joined:
    Oct 21, 2005
    #1
    Is there a way to show previously hidden file extensions for many files at once?
    (I know it's usually a matter of doing a Finder "Get info" and unchecking Hide extension, but that's only helpful for one or two files).
    An app, a Terminal command or whatever will do fine. Thanks
     
  2. RMo macrumors 65816

    RMo

    Joined:
    Aug 7, 2007
    Location:
    Iowa, USA
    #2
    Does it work if you select multiple files (drag a rectangular selection box with the mouse, starting in a "blank" area of the file list in Finder, or hold down Cmd and click them all) then right-click, hold down Opt, and choose "Get Summary Info"? I'm not sure if that actually lets you change the show/hide extension option for multiple files, but if it does it's certainly easier than doing them individually. (Obviously, this is easier if all the files are in the same folder.)

    Personally, I turn on all file extensions. In Finder, you can do this with the Finder | Preferences menu item, then choose the "Advanced" tab and check "Show all filename extensions" (it will take some getting used to seeing .app after all of your application bundles, but I really prefer this because it ensures I never accidentally hide an extension by forgetting to type one when I save the file or whatnot). I'm not saying this is the best option for you, but if you never want to hide file extensions, it's something you may wish to consider. Others may have to chime in if neither of these two options works for you.
     
  3. kaibob, Jun 8, 2015
    Last edited: Jun 8, 2015

    kaibob macrumors regular

    Joined:
    Jun 21, 2010
    Location:
    Prescott, Arizona
    #3
    I tried RMo's suggestion and it didn't work at first. Selecting "Show Inspector" from the right-click menu did work.
     
  4. macstatic thread starter macrumors 6502a

    Joined:
    Oct 21, 2005
    #4
    Yes, you're right! Thanks.

    1) Select the files you want to have the file extensions shown for
    2) right-click to get the contextual menu
    3) once you see the contextual menu, press ALT (which will change "Get info" to "Show inspector")
    4) select "Show inspector"
    5) Remove the tick mark next to "Hide extension"

    Saved me a lot of time!
    Turning on all extensions as RMo suggested might also be an option worth looking into.
     

Share This Page