Showstopper AIM bug--messages missing!

Discussion in 'iOS Apps' started by red9, Jul 4, 2009.

  1. red9 macrumors member

    Joined:
    Jul 4, 2008
    #1
    I was just wondering if anyone else has noticed a rather significant bug/issue with the latest version of AIM (I only recently got an iPhone so I don't know if this issue was present on any previous version).

    Basically, it seems that if you are relatively active and opening applications and/or doing other stuff on the phone and receive multiple AIM messages, you will receive the push notification of the message and/or (depending on your push settings) the badge icon indicating the # of messages received, however once you open AIM to read the messages, one or more messages received may simply NOT BE THERE at all (even if you could READ the message from the push notification!)..

    I was browsing the AOL iblog and found this comment posted which seems to indicate that it isn't an issue isolated to my phone:

    "I'm running 3.0 with the paid version of this app on a 3g iPhone. The problem I'm running into is when the app is closed and I'm doing anything else. I'll see a badge on the icon alerting me of new IMs but when I open the app only 1 will show up, the most recent. This is very frustrating. For example I had 6 new messages according to the badge, I opened the program and all I see is a one word IM correcting the spelling of what I can only assume is from one of the 5 IMs that are missing. Is this a known issue? Is there any fix for this currently? The fact that this is the paid version makes it that much more frustrating that it seems to be losing messages."

    From my experience it seems to be random in terms of how many messages get lost. Also, it seems that if your phone is just sitting there idling at the home screen then messages appear to NOT get lost and do appear properly (I tested this briefly but not exhaustively, so don't quote me on this).

    So, anyone else notice this? Has anyone noticed this on any other IM apps such as Beejive? Any idea on a workaround, or do we just have to hope AOL decides to fix their issues? It appears to be 'random' enough that not many people have noticed it (hey, you simply might never have received the message, or received 3 out of 4 messages with the ones you received not cluing you in to the fact that one message might be missing, leaving you blissfully unaware that message(s) are missing) so hopefully this post gets some attention to the bug.
     
  2. kornyboy macrumors 68000

    Joined:
    Sep 27, 2004
    Location:
    Knoxville, TN (USA)
    #2
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

    This is interesting. I have not experienced this with the Free/ad-supported version of the app. This is a major problem though.
     
  3. rammy macrumors member

    Joined:
    Dec 25, 2007
    #3
    I've been experiencing exactly the same issues.

    I also find the app' really sluggish, especially on GPRS and 3g.
     
  4. red9 thread starter macrumors member

    Joined:
    Jul 4, 2008
    #4
    I am running the free/ad-supported version on an iPhone 3G (I guess one thing to consider is if this is an issue more prone to the iPhone 3G vs the 3GS).

    Glad to see at least one other person is experiencing the same issue. Honestly, I think the issue is most likely there, it's just that either:

    1) you just happened to not be doing anything else to have caused it to happen (as it definitely does appear to be semi-random in terms of when it happens) or...
    2) you just happened to not notice. If someone sends you only 1 message and it doesn't arrive because you happen to be loading a level in a game or doing *something* at the moment a message arrives that causes it to disappear, there is probably no evident issue to you. Likewise, as I said in my previous post, if someone or multiple people are sending you multiple messages that don't happen to reference each other, it's very easy to just be oblivious that one or more messages may have been lost.

    Now, I'm not sure about anyone else's thoughts, but IMO the LAST thing an instant messaging application should EVER do is LOSE messages under ANY circumstance.

    Again, I hope AOL or whoever is developing this app becomes aware of this and gets it fixed in future versions, as an IM app that loses messages is quite ridiculous, especially for those who paid for it.

    Has anyone who HAS experienced this message loss switched/used any of the other push-based IM apps like Beejive or IM+?
     
  5. mrrish macrumors regular

    mrrish

    Joined:
    Feb 14, 2008
    #5
    I am also on the free version and I get this same exact problem. I thought it was just me being forgetful on an otherwise extremely busy day!
     
  6. red9 thread starter macrumors member

    Joined:
    Jul 4, 2008
    #6
    I noticed that IM+ is on sale for $4.99 at the moment, does anyone have any experience with IM+ EVER losing message for whatever reason like AIM seems to do? If not, I might pick it up because like I said before, an IM app lossing message is just :eek::confused:
     
  7. Identity Fraud macrumors 6502

    Joined:
    Sep 11, 2009
    #7
    I hope I don't get killed for bumping an old thread, but this is what I'm going through as well and there was never a fix posted in this thread.

    iPhone: 3.1.2
    Carrier File: 5.6
    AIM: 4.0.1.30

    I'm having the same problems as the original poster. Has anyone found a better IM program that doesn't do this? I dont get how it gets lost, I get the pop up that has what my friend said, load AIM and the conversation doenst get updated - or if it does it's missing a few lines.
     

Share This Page