SHSH Blob Game Changer in iOS5 [Dev-Team]

Discussion in 'iPad Hacks' started by this is funah, Jun 27, 2011.

  1. this is funah macrumors 6502

    this is funah

    Joined:
    Oct 13, 2005
    Location:
    Berlin, Germany
    #1
    http://blog.iphone-dev.org/post/6952986620/blob-monster

    i guess people are really going to need to avoid upgrading from Fall on.
     
  2. Siggen macrumors 6502

    Joined:
    Apr 1, 2011
    Location:
    Oslo, Norway
    #2
    Looks like we're in for nasty weather.

    Nah j/k this will just be another minor inconvenience while jailbreaking,
    And might be possible to circumvent.

    If they enforce this after beta (i bet they will), its gonna suck for those who want to downgrade to iOS 5.x.x +
    Luckily this is a minority.
     
  3. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #3
    I don't see this being a big deal at all. I've never felt the need to ever downgrade my main firmware. Once the latest firmware is jailbroken I get on it. Only thing I'd be concerned about is the ability to maintain an unlock while being on newer firmware.
     
  4. anthdci macrumors 6502a

    Joined:
    Jun 8, 2009
    #4
    It is not so much the downgrade but it is also if you ever have a problem and have to restore you will have to update to a possibly un jailbreakable iOS
     
  5. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #5
    I never had any problem after jailbreaking thus see no needs to restore.
     
  6. lakerchick4life macrumors 6502a

    Joined:
    Oct 14, 2007
    #6
    So let me understand how this works..lets say(Since I am on 4.3.3 right now) and I jailbreak(When jailbreakme comes out for my iPad 2) and I have some kind of issue with the iPad and I have to restore..I would have to upgrade to IOS 5 even though I already saved my SHSH blob for 4.3.3..I cant just restore to 4.3.3?
     
  7. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #7
    I have copy and paste the answer from the original post for you.

    "Also, restoring to pre-5.0 firmwares with saved blobs will still be possible (but you’ll soon start to need to use older iTunes versions for that)."
     
  8. anthdci macrumors 6502a

    Joined:
    Jun 8, 2009
    #8
    if you have the 4.3.3 blobs you can always downgrade/ restore to that. However if you buy a device that is on iOS 5 and you cant get the 4.3.3 blobs you will be forced to go to the latest version. Take this scenario

    Buy an iPhone4 on iOS 5.0 (when it is released)
    jailbreak (obviously if/when this is released)
    apple release iOS 5.1 (no jailbreak available)
    your iPhone4 craps up and you need to restore.
    You are forced to go to the un-jailbreakable iOS 5.1

    this is why having blobs backed up helped incase anything went wrong, by the look of it backing them up will no longer be an option.
     

Share This Page