SHSH locally but unable to downgrade

Discussion in 'iPhone' started by megalolz, Aug 26, 2010.

  1. megalolz macrumors newbie

    Joined:
    Aug 26, 2010
    #1
    guys, can i tickle someones brain?

    i had an iphone4 on 4.0.1 and managed to back up my SHSH via tiny umbrella fine. as far as im aware, this is also on cydia too. the file is also on my local machine and is named xxxxxxxxxxxxx-iphone4-4.0.1.shsh

    i sold this phone and bought another running 4.0 and did the same thing... or so i thought.

    the file is named yyyyyyyyyyyyy-iphone4-4.0.2.shsh. having made a backup of my previous phone via itunes, when i got the new one i simply restored from backup and all was well till some games started to crash. i figure that it must have been a 4.0 issue but was a tad late updating to 4.0.1 as apple has stopped signing 4.0.1 firmware.

    i have tried everything, read everywhere on how to do a downgrade and not succeeded. i am now running 4.0.2 and looking ever so likely that i cannot downgrade to 4.0.1 anytime soon, unless some helpful soul can assist.

    Tiny umbrella shows that the following devices/ECID can be restored...
    iPhone4 4.0.1 (8A306)-xxxxxxxxxxxxx
    iPhone4 4.0.2 (8A400)-yyyyyyyyyyyyy

    What gets me is why does it show iPhone4 4.0.2 (8A400)-yyyyyyyyyyyyy can be restored when i never have upgraded to 4.0.2 prior to get the SHSH?

    When trying to do the restore to 4.0.1, itunes just errors and gives 3002 despite me changing the hosts file and also enabling the TSS server in TU.

    I just cant seem to get it to work. Anybody know why? I can give more information if need be.

    Thanks
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    SHSH hashes are specific for each phone. Your 4.0.1 hashes are for your old which is useless for your new phone. Whatever hashes can currently be saved has nothing to do with what is on your phone. It has to do with what Apple is currently signing, at your time 4.0.2. And, that's why you have 4.0.2 and not 4.0 or 4.0.1. You are pretty much stuck at 4.0.2 and will have to wait for 4.1 JB.
     
  3. megalolz thread starter macrumors newbie

    Joined:
    Aug 26, 2010
    #3
    Myzhi, i was hoping you'd reply. I noticed you was very detailed with your answers when i was browsing through the forums earlier.

    Question to you is... how come the SHSH for the new phone isnt showing as iPhone4 4.0.1 (8A306)-yyyyyyyyyyyyy when it was extracted from TU a couple of days after but way before Apple stopped signing 4.0.1?

    The new phone was 4.0. Thats what I dont understand.
     
  4. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #4
    Try this in Tinyumbrella:
    1) Make sure you Iphone is detected.
    2) check "Advanced Options."
    3) In new window, under "Device / Version," select 4.0.1 firmware.
    4) Click on "Save my SHSH." Pray Cydia has them. If you don't get an error, it has been saved onto your computer.
    5) Repeat to save other firmware hashes if you wish.
    6) Now, click on "Display SHSHs." It should listed all hashes you have saved on your computer and can downgrade to.
    7) Start "TSS server" and restore through iTunes with firmware shown in #6.
     
  5. megalolz thread starter macrumors newbie

    Joined:
    Aug 26, 2010
    #5
    tried. doesnt work. Cydia doesnt have it saved, which is bizarre. the file i have is iPhone4 4.0.2 (8A400)-yyyyyyyyyyyyy only. strange when i did it exactly the same way which is whats confusing me.

    i doubt there are any other things i can do. guess i can only wait. its not the end of the world but just wanted to have the option there to jailbreak if need be.

    no doubt 4.1 will be jailbroken soon. anything else that i can try in the mean time?
     
  6. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #6
    Without 4.0.1 SHSH hash saved, nothing you can do. Just have to wait for 4.1 JB.

    Awhile ago, Apple for some reason signed both 4.0.1 and 4.0.2 at the same time. Maybe, specify 4.0.1 to be save and instead only got 4.0.2. It's to late anyway no point in wondering about it at this time.
     
  7. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #7
    It sounds like you only managed to save the SHSH blobs for 4.0.2. I find it hard to believe you did it before they stopped signing 4.0.1 as Tinyumbrella always defaulted to saving 4.0.1 when both were being signed. Also the firmware on your phone has nothing whatsoever to do with what SHSH blobs you can get.
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    The SHSH is not extracted or even saved on the iphone itself.
    Its released by apples servers when the phone tries to restore thru itunes or is grabbed and saved by tinyumbrella or cydia.
    Sounds like your SOL for now.
     

Share This Page