SHSH on Cydia?!

Discussion in 'Jailbreaks and iOS Hacks' started by Scrapsterelly, Apr 13, 2010.

  1. Scrapsterelly macrumors newbie

    Joined:
    Apr 13, 2010
    #1
    I have read a lot of articles and just can't get my head around what I need to do next.

    I have an iPhone 3GS - which I jailbreaked on 3.1.2 and then stupidly without thinking upgraded on iTunes to 3.1.3 and lost my jailbreak!

    I have read about SHSH being stored on Cydia, and i'm not sure how to check if it is or not.

    If it is, as I understand it, I will be able to go through a rather lengthy process which will downgrade me to 3.1.2 and I can then re jailbreak. I think this is correct.

    My real problem is therefore how do I go about checking if I stored my SHSH on Cydia? Do i need to reinstall Blackrain etc on my computer and go through all of that process as I did when initially jailbreaking my phone, to get Cydia back, and then be able to load it to see if the green writing confirms that SHSH info is stored?

    Thanks in advance
     
  2. xxBURT0Nxx macrumors 68020

    xxBURT0Nxx

    Joined:
    Jul 9, 2009
    #2
  3. Scrapsterelly thread starter macrumors newbie

    Joined:
    Apr 13, 2010
  4. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #5
    easy; it wasn't automatic, so you should remember clicking the button 'make my like easier'. If you did this before apple stopped signing the 3.1.2 FW you're in luck.


    Yes, though if you think editing a single line of text in a single hosts file as 'lengthy', perhaps attempting it is a mistake.
     
  5. Scrapsterelly thread starter macrumors newbie

    Joined:
    Apr 13, 2010
    #6
    Ok, well nothing i've done has worked so far.

    I edited the host file, saved it then followed the instructions to restore, and then I get to the section where it tells me to press the Option Key and select the IPSW, i've downloaded an IPSW 3.1.2, however there is no option key on a PC!

    So restoring simply took me back to 3.1.3

    I've downloaded Redsn0w and tried to run that with the 3.1.2. IPSW but none of the files in the IPSW had the extension *.ipsw so I couldn't do that...

    I'm clearly not getting anywhere fast!
     
  6. Benji222 macrumors 65816

    Benji222

    Joined:
    Dec 21, 2009
    Location:
    So Cal
    #7
    you shift click restore on a pc :D
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Yes.
    After that if it let's you restore to 3.1.2 you're good.
    If not and you edited your hosts files correct then it means you don't have the shsh's saved for 3.1.2
     

Share This Page