Shure SM57 w/ Blue Icicle Stopped Working

Discussion in 'Mac Accessories' started by andrewoc, Dec 1, 2010.

  1. andrewoc macrumors newbie

    Sep 18, 2009

    Ok, here it goes. Basically, I've used my Shure SM57 mic with the blue icicle usb adapter for months now. I don't think I've ever had a single problem. All of a sudden, it has stopped working. I don't know what is the fault, and I'm not sure how to text it. I have no interchangeable products for either piece of equipment. I have tried garageband, photobooth, and audacity, all to no success. I have clicked it in the system preferences of course.

    So this thread really is a shot in the dark. If you have any ideas on what I should check before I try contacting the companies, please let me know.

  2. Capt Underpants macrumors 68030

    Capt Underpants

    Jul 23, 2003
    Austin, Texas
    It's not likely to be an SM57. You'd have a hard time killing that thing if you were hell bent on it.

    You don't know anyone with an extra mic or mic cable? If you can eliminate those possibilities, then it must be the icicle -- or some kind of software issue.
  3. andrewoc thread starter macrumors newbie

    Sep 18, 2009
    I literally never take it off the stand, never drop it, nothing - so it probably isn't that. Software, doubt it. I tried many applications, I can try it out on my sisters Macbook later to be sure, though. I guess it must be the icicle (good thing I bought the insurance xD),

    Thanks, anyone else have any ideas?

Share This Page