Shutdown , restart.... Never successful.

Discussion in 'OS X El Capitan (10.11)' started by Soundburst, Jan 10, 2016.

  1. Soundburst macrumors 6502a

    Joined:
    Oct 4, 2006
    #1
    Hey everyone,

    My iMac has never ever shutdown properly, or restarted.

    Well I exaggerate. It has a few times.

    Usually the menu bar disappears and boom... That's it. It'll stay on that screen forever.

    Why does this happen? Anyone know?
     
  2. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
    Try downloading the OS X installer again and run over your install. While it should be safe, it's always recommended that you backup first. I suggest a clone backup in addition to Time Machine.

    Under Purchases in App Store, find the OS X installer. It will tell you it's already installed but you can select Continue to download again.
     
  3. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #3
    This used to happen to me on Yosemite, however I would still be able to access the Dock. I would open terminal and run the command from the link below and it would shutdown without probs:

    http://apple.stackexchange.com/ques...-command-to-shutdown-restart-and-sleep-my-mac
     
  4. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #4
    I've been having a similar problem myself.

    I've got a late-2012 Mac Mini, but I'm booting into El Capitan from an external SSD mounted in a USB3/SATA "adapter dongle".
    The Mini has 10.8.5 installed on its internal drive.

    If I'm booted to El Capitan, and choose "Shut Down" from the finder, I get a crash (kernel panic).
    And then the Mac automatically reboots to 10.8.5 on the internal drive.

    This is repeatable -- happens every time.

    HOWEVER, I've found a workaround:

    When it's time to shut down or restart, I -log out- first.
    Now, I'm looking at the login page, which also has "Shut Down" and "Restart" buttons at the bottom.
    I can now press either button and the computer will shut down or reboot properly.

    OP:
    If you attempt to log out before you shut down, do you still get a crash?
     
  5. Soundburst thread starter macrumors 6502a

    Joined:
    Oct 4, 2006
    #5
    Thanks for all the replies guys. I logged out first and it didn't stall at the desktop. I'll keep doing this.

    Cheers for all the input.
     
  6. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    You may have a corrupt User Account. Create and log into a new User Account and test the shutdown.

    If you find that it works with the test account you should probably address the corrupt one as other issues may arise.
     
  7. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #7
    This is a followup to my post #4 above, and in response to Brian in post #6 directly above.

    I tried creating a brand-new-spanking-fresh account.
    I then logged out of my regular account into the new one.
    I get the exact same crash upon trying to shut down as before.

    Whatever this is, it doesn't seem to be "user account related".
     

Share This Page