Shutdown while startup, disk full error on verbose

Discussion in 'MacBook Pro' started by dario.crucil, Apr 30, 2014.

  1. dario.crucil macrumors newbie

    Joined:
    Apr 30, 2014
    #1
    i have a mac book pro when starting , the gray screen appears, later the apple and 10 seconds later aprox, turn off

    i try verbose mode and after turn off i can see a message “Disk full error"


    Operating system: OSX 10.9

    322MB FREE OF 300GB .. (my girlfriend is a graphic designer and does not pay any attention to alerts ..)

    I prove, smc reset, 2 chime sound test, safe mode (turn off too).

    performing tests were:



    1. Launch the recovery console ( from bootable usb osx mavericks) ,

    a. i probe unmount the volume Macintosh HD, not possible, because, its in use.
    b. verify disk ( Macintosh HD) , "the disk needs to be repair"
    c. repair disk ( Macintosh HD) , Keys out of order , ... Utility cant repair disk , and restore your backed -up files
    d. Check disk (320gb toshiba ..) , the partition map need to be repaired , because ... Problem with the EFI system partitions
    e. repair disk (320gb toshiba ..) , but ... when repair , try with Recovery HD, and works fine (not Macintosh HD)


    After that, the disc automatically unmounts and its not possible mount again (from terminal said "mount: /dev/disk0s2: unknow special file of file system")



    2 . Probe I start with a recovery console (local disk)

    same results (on repair 320gb toshiba.. the first time i run it, said "can’t perform live”, after that, same result like point 1



    3. restart, with recovery console (local disk)

    a. launch terminal and try to delete manually , go to /dev/disk0s2 (/Volumes/Macintosh HD) and can browse the disk (ex /Users/xxxx/Desktop), but when tried rm, appears “Read-Only File System

    4. Remove the HD from mac and put it on case, when i connect it via USB to another mac book pro, the OS, saids “can’t recognize the disk, initialize, ignore, eject)





    it is possible unmount the volume and remount like read-write from recovery console?
    is it possible to access the data in read-write mode for any way to delete some huge files?



    its the only solution mount and external disk and make and tedious scp from Terminal???, if its possible






    regards, sorry for my bad English

    Dario
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    It sounds like you have a bad drive there that needs to be replaced.

    If you can't get it to mount from a USB enclosure on another Mac, you are not likely going to be able to recover data from it. You could try the utility Disk Warrior, but is not free. Or you can pay a company to try and recover the data for you, but that can ve very expensive.
     
  3. Barney63 macrumors 6502a

    Barney63

    Joined:
    Jan 9, 2014
    Location:
    Bolton, UK.
    #3
    It seems his disk is readable, he just can't write/delete files.
    If all else fails you should be able to copy all your data to another disk.


    Barney
     
  4. dario.crucil thread starter macrumors newbie

    Joined:
    Apr 30, 2014
    #4

    thanks for the update.

    right now, im make some free space on external disk to try to copy from terminal.

    in a few hours I will have updates


    regards
    Dario
     
  5. dario.crucil thread starter macrumors newbie

    Joined:
    Apr 30, 2014
    #5
    finally, i made a backup from User profile folder.
    After that runs Disk Warrior and this AWESOME application fix some errors, related with:

    - bad sector allocation
    - files with repaired flag
    - incorrect size
    - incorrect values with Volume Information



    later restart the mac, and works fine (with 120mb free), just delete some GB, and work fine again.

    thanks, for the reply

    Dario
     

Share This Page