shuts down after apple logo

Discussion in 'MacBook Pro' started by carlos28355, Nov 25, 2015.

  1. carlos28355 macrumors newbie

    Joined:
    Sep 6, 2012
    #1
    have a mid 2012 a1278 MacBook Pro 13"

    its shutting down shortly after apple logo appears. Here's what I've done

    I Believe I have formatted the hdd using a program In Windows. partion wizard or something i say I believe because it almost seemed as if it did not work but im not sure.

    ive changed hdd

    i ran apple hardware test. It passed

    i ran Apple service diagnostic test and it also passed.

    Neither of the scans shut down. In fact it stayed on for hours until I forced it to shut down

    Tried taking the battery out.

    Tried to to boot to el Capitian usb installer but it shuts down when it tries to boot to that.

    The mac stays on when i try different boot functions. For example when i hold down X it will stay on and even eventually get to my log in but when i let go of the key it will shortly shut down. Also stays on when im at the screen to choose which device i want to load into. but when i click on the hdd/recovery/ or when trying to CD

    Any other suggestions would be grand. Thank you kindly
     
  2. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #2
    try resetting the SMC, and resetting pram (you can google for how-to for your particular model).
     
  3. carlos28355, Nov 25, 2015
    Last edited: Nov 26, 2015

    carlos28355 thread starter macrumors newbie

    Joined:
    Sep 6, 2012
    #3
    I failed to mentioned i have reset the pram. Although i will try again just in case. Out of all my research i have not come across anyone mentioning SMC so thank you for that I will try it and report back to you!

    UPDATE:
    i did the reset for SMC and pram but it didnt do anything for me. but what i have come to realize from all this is that as long as a key (ANY KEY) is pressed down on the keybaord the laptop will remain on....??? what kind of black magic is this???

    UPDATE 2:
    Something going on with power. My battery is not recognized any longer. I even tried coconut battery and its like theres no battery plugged in. I do n to believe this to be the cause of my problem because the laptop acts the same when i unplug the battery. There is a black x on the battery symbol. And the computer thinks I'm not plugged in because it will say the battery is low and will go to sleep if i don't charge it. Also during reinstalling El Capitan it said i needed to be connected to a power source. I have used multiple adapters and didn't make a difference. Maybe the DC board is bad as far as that goes. Anyone know if that can cause my other problems of random shut down? Maybe it can be related...
     

Share This Page