Sierra & FTP connection issues

Discussion in 'macOS Sierra (10.12)' started by itspmm, Oct 22, 2016.

Tags:
  1. itspmm macrumors newbie

    Joined:
    Oct 22, 2016
    Location:
    Geelong, Australia
    #1
    Since I upgraded to Sierra, I am having FTP issues in that once connected to my remote server, it fails to retrieve the directory. I have been in touch with my host service and they have established that I do connect successfully to the server, so as far as they are concerned, that is not the issue. I am simply trying to FTP files from my Mac to a hosted server, not run my own FTP server. I manage several web sites for small voluntary groups, so my needs are fairly basic and I'm very familiar with this protocol.

    I learned a lot about Macs and PCs along the way in my previous jobs at a university, but was never a technician. I moved from Finance to providing desktop/networking support for both Macs and PCs back in the 90s until my retirement in 2002.

    I do not have the Firewall turned on. This is happening with every single account I try to FTP to and I am using Filezilla as my client. I have tried other FTP software with similar results. On El Capitan, the problem turned out to be the networking hardware MTU setting - once I changed that to be the same as the MTU setting on my router, it worked fine. I don't think that applies here as I am now using a cable/ethernet connection. On the cable gateway, the firewall is set as 'normal' and I do not control that setting, although I now have Port Blocking turned off in my internet service, at my request.

    Since I use a Mac, tech support eyes tend to glaze over a bit when it comes to offering solutions.... Admittedly, this sort of thing does not crop up when I use a Windows PC on the same network. I consolidated everything back to my Macs a couple of years ago and I really don't want to go there ever again....

    Has anyone else come across this? Anyone found a solution? I went through all this stuff when I migrated to El Capitan and it took weeks for the eventual solution to show up, after much diligent searching - it was the MTU setting.
    Someone on another forum suggested I roll back to El Capitan - horrible thought! I don't think I have the patience nowadays to go though the hoops for that. Thanks everyone.
     
  2. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #2
    tried turning on (or off) passive mode?

    By the way, I don't have access to servers anymore that have ftp daemons running. Just sshd.
    So I sftp to the vps/shared/dedicated, etc with Transmit.

    enter the ip and port of the ssh connection, and the right user account. accept the key on connection and you're in.

    hasnt' failed for me yet.
     
  3. itspmm thread starter macrumors newbie

    Joined:
    Oct 22, 2016
    Location:
    Geelong, Australia
    #3
    Maybe you could explain a bit more how to do this (sshd), since I really don't know where to begin. I'm happy to learn and if it works, I'll continue to do it.

    I tried your suggestion about active/passive - active resulted in the connection being refused.

    Passive gave me this result:

    Status: Resolving address of sgp21.siteground.asia
    Status: Connecting to 181.224.157.152:21...
    Status: Connection established, waiting for welcome message...
    Status: Logged in
    Status: Retrieving directory listing of "/public_html"...
    Command: CWD /public_html
    Response: 250 OK. Current directory is /public_html
    Command: TYPE I
    Response: 200 TYPE is now 8-bit binary
    Command: PASV
    Response: 227 Entering Passive Mode (181,224,157,152,135,143)
    Command: MLSD
    Error: Connection timed out after 20 seconds of inactivity
    Error: Failed to retrieve directory listing
    Status: Disconnected from server

    I removed the timeout after inactivity mode in preferences and it just sits there...
     
  4. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #4
    Though I don't recommend giving your credentials to a public site (so know how to change the pass a minute later I guess)
    https://ftptest.net//
    You could test to see if a service like that has any issues and if so why.
     

Share This Page