Sierra no wake from sleep with some video kexts [solved]

Discussion in 'macOS Sierra (10.12)' started by sbuntin, Jul 8, 2016.

  1. sbuntin, Jul 8, 2016
    Last edited: Jul 8, 2016

    sbuntin macrumors member

    sbuntin

    Joined:
    Aug 2, 2011
    Location:
    Portland OR
    #1
    Hope this helps some folks.

    MacBook (Retina, 12-inch, Early 2015), Sierra 10.12 Public Beta (16A238m)

    On waking macbook, backlight would come on, but no video on display and system appeared unresponsive.

    I tried removing a number of startup items, but the problem remained. Eventually I found this article, suggesting some non-apple display drivers could be a problem - https://www.reddit.com/r/apple/comments/4rrx0s/duet_display_may_prevent_macos_sierra_from_waking/

    Code:
    $ kextstat | grep -v com.apple
    
    Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
    
      112    1 0xffffff7f80c66000 0xa000     0xa000     com.avatron.AVExVideo (1.7) 7F642CAD-514F-3539-9DF1-A36ABDC91352 <73 5 4 3>
    
      113    0 0xffffff7f80c70000 0x9000     0x9000     com.avatron.AVExFramebuffer (1.7) 9B4554BB-E74F-3571-9C60-1FE38DAFC865 <112 73 5 4 3>
    
    I did not have Duet Display installed, but I did have Avatron's /Library/Extensions/AVVideoCard.kext and /Library/Extensions/AVFrameBuffer.kext. These are apparently part of an iPad-as-second-display utility.

    Removing them and restarting solved the problem.
     
  2. hugocésar macrumors newbie

    Joined:
    May 13, 2016
    #2
    Thank you so much! I've spent the whole day with this problem. Gave me a headache.
     
  3. sbuntin thread starter macrumors member

    sbuntin

    Joined:
    Aug 2, 2011
    Location:
    Portland OR
    #4
    Glad it helped!
     
  4. smharm13 macrumors newbie

    Joined:
    Apr 15, 2010
    #5
    Worked for me as well. Removed AVFrameBuffer.kext and AVVideoCard.kext did the trick!
     
  5. Stevencwong macrumors newbie

    Stevencwong

    Joined:
    Jul 10, 2016
    Location:
    Toronto
    #6
    For me, it was Splashtop Streamer that caused the issue. After it was uninstalled, this issue was resolved.

    S.
     
  6. arnoldmukisa macrumors newbie

    arnoldmukisa

    Joined:
    Jul 22, 2016
    #7


    This solved it mine was Air Parrot
     

Share This Page