Sierra requiring OS-X 10.7.5 or later

Discussion in 'Mac Basics and Help' started by Texas_Toast, Mar 31, 2018.

  1. Texas_Toast macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #1
    On Apple's website, it says under requirements, that OS-X 10.7.5 (Lion) is required.

    What does that mean?

    Does that mean that if you are doing an OS update, you have to att least be running Lion?

    Because if your hardware is compatible, and you were installing macOS Sierra from a thumb-drive, I wouldn't think the current OS you have would make any difference. (In fact, if you formatted your HDD, and then used an installer, whether your Mac used to have Lion or not would be immaterial, right?)
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Correct... this is because Lion was the first version to have the App Store and you need ccess to the App Store to download Sierra.

    But if you already have Sierra on a USB key, it does not matter like you mentioned.
     
  3. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #3
    Thanks!
     
  4. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #4
    Incorrect. The App Store first came to the Mac with a Snow leopard update, 10.6.6.
     
  5. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #5
    Snow Leopard was 10.6, so if you are correct about the App Store being available with Snow Leopard 10.6.6, then it would seem that Apple would want people to have Lion (10.7) in order to successfully be able to access the App Store.

    Sounds like there is truth in what you both say!
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    Gah... you are correct and I had a brain freeze. I was thinking this is the first version you could download from the App Store and confused myself.
     
  7. Texas_Toast thread starter macrumors 6502a

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #7
    @Weaselboy, but your larger reasoning - as mentioned above - seems to be correct...

    Apple recommends that people have Lion so they can easily access the App Store.

    To @Dave Braine's point, I suppose they could say "Snow Leopard v10.6.6" required, but they probably felt it better to just recommend having the next version.

    Just my two cents.
     
  8. bcave098 macrumors 6502a

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #8
    I believe they stopped allowing direct upgrades from Snow Leopard to simplify the installer (since it doesn't need to include updates made between 10.6.8 and 10.7.5). Before Sierra, you could upgrade from 10.6.8 directly to the latest version (up to 10.11.6).
     

Share This Page