Sierra Upgrade - Can't Launch Any Apps or Open Documents - Two Everyone Permissions Randomly Added

Discussion in 'macOS Sierra (10.12)' started by DC3400, Jul 17, 2017.

  1. DC3400 Suspended

    DC3400

    Joined:
    Jan 2, 2009
    Location:
    Smarties Land
    #1
    Upgrading from Mavericks to Sierra:

    1. Clicking any application in dock, 3rd party or Apple, makes the dock animate downward off bottom edge of screen and back upward while both screens flash black for a moment. App is not launched.

    2. Clicking documents makes any open Finder windows disappear and reappear and icons the Desktop disappear and reappear. Document not opened and its default app not launched.

    If one does this several time a dialog window may appear from time to time:

    "The last time you opened Finder it unexpectedly quit while reopening windows. Do you want to try to reopen its windows again? If you choose not to reopen windows, you may have to open and position the windows yourself."

    Sometimes the previous open Finder windows do not reappear and I need to click the Finder icon.

    3. The only way to use any apps; for instance Safari, is to add it to the Login Items under the Admin account, and restart. If any of these apps are quit they can't be restarted unless you reboot with them added to the Login Items.

    4. Tried Disk Utility and reinstall of Sierra via Internet Recovery and did not fix the issue.

    5. Booted into safe mode and same symptoms.

    Erased HD and Completed Fresh Install of Sierra:

    1. Worked for several days then the above problem returned after shut down the Mac for one day and restarting it. I usually leave the Mac running and let it fall to sleep, but was going tone gone for the day and thus shut it down.

    2. Tried Disk Utility and Reinstall Sierra via Internet Recovery and did not fix the issue.

    3. Booted into safe mode and safe problem.

    Second Everyone Permission

    In both cases I have noticed that a second "Everyone" with "Custom" privileges has been randomly added to various items by Sierra as thus:

    Everyone - Custom

    (my user name) - Read & Write

    staff - Read only

    Everyone - Read only

    Why is Sierra denying access to apps and files? Why is the Finder not working?
     
  2. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #2
    When you say fresh install did you do a clean install or just reinstall Sierra on top again?

    And after you did a fresh install of 10.12 did you restore from Time Machine? And your restore from Time Machine was that a restore of any system files or just user data,
     
  3. DC3400 thread starter Suspended

    DC3400

    Joined:
    Jan 2, 2009
    Location:
    Smarties Land
    #3
    Thanks for your reply.

    The first time Mavericks was already installed and I upgraded to Sierra via Apple's update option.

    The second time I booted into internet recovery mode, erased the HD entirely, and installed Sierra.

    Time Machine was not involved at all. I had been using CCC; however, it had been turned off at some point, thus there were no updates to fall back on.

    I finally decided to create a newer admin account and continue installing apps via that account. This new admin has had no issues thus far. It appears that Apple's upgrade from Mavericks to Sierra and Apple's clean install of Sierra on a erased hard drive (both via internet recovery mode) corrupted the original admin account.

    As I also run VirtualBox and SheepShaver the reinstallation of hundreds of apps and configuring each of the other OSs has taken about 3 weeks as I have to retrieve the software's registration codes, etc... I still have a few more to go. Fortunately I keep copies of all the original software dmg, sit files and registration information on a separate HD within an app archive. Its also fortunate I keep all pictures, music files, and other use generated content on other HDs as that represents years of work.

    Lesson learned. Now Time Machine is used to make hourly saves on the main OS on another HD. I'll also be using CCC to create a bootable backup on another HD. Prior to any further updates from Apple I'll be creating a new admin account and then trashing the old one after the update just to be safe.

    LOL, Apple wanted me take the Mac to a Apple Store or Authorized Repair Center - apparently Apple thinks everyone lives in a large city. I think the closest Apple Store is at least 120 miles one way.
     
  4. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #4
    Good that you got it sorted out. You should not have to create a new admin account when you do an update. Something else must have gone wrong that a clean install solved.
     

Share This Page