Significant Delay following login

Dave Marsh

macrumors regular
Original poster
Jul 23, 2002
210
0
Sacramento, CA
Hi all. :) One on my users at work is having a significant delay after logging into her account and before the desktop finishes loading the dock, top menu bar, and desktop icons. The spinning beach-ball spins up to 30 seconds while something is happening in the background. There's nothing set to startup in her account following login, including no antivirus or file saver background applications. Also, this machine boots up quickly leading up to the login screen (~13 spins).

This machine is a 700MHz eMac with 768MB of RAM. This machine has recently been upgraded to 10.3.8, and fully defragmented (using iDefrag). If I log into the Administrator account, its dock, menu bar and desktop icons load within 5-10 seconds, with virtually no beach-ball activity. The problem seems to be localized specifically to her Finder desktop area. Her desktop is clean except for the Macintosh HD icon and dock. The dock only has the standard icons plus Word, Excel, PowerPoint, and her Mail client.

Since I'm sure there's no special background apps starting up when she logs in, I'm left to wonder if there's a cache that is being read that may be corrupted that's delaying everything. Does anyone have any idea what the names of the caches are that may be involved following the login process? Even though I'm sure the caches aren't fragmented (the problem persisted both before and after defragmenting), they may be damaged, and I'd like to delete them to force the OS to rebuild them.

I'm really quite puzzled at this point, since there's no delay at all when logging into the only other account on this machine (Administrator). I don't really want to create a new account for her and move all her data over to it just to fix this issue, but will if I have to.

Thanks for listening... :confused:
 

superbovine

macrumors 68030
Nov 7, 2003
2,872
0
Dave Marsh said:
Hi all. :) One on my users at work is having a significant delay after logging into her account and before the desktop finishes loading the dock, top menu bar, and desktop icons. The spinning beach-ball spins up to 30 seconds while something is happening in the background. There's nothing set to startup in her account following login, including no antivirus or file saver background applications. Also, this machine boots up quickly leading up to the login screen (~13 spins).

This machine is a 700MHz eMac with 768MB of RAM. This machine has recently been upgraded to 10.3.8, and fully defragmented (using iDefrag). If I log into the Administrator account, its dock, menu bar and desktop icons load within 5-10 seconds, with virtually no beach-ball activity. The problem seems to be localized specifically to her Finder desktop area. Her desktop is clean except for the Macintosh HD icon and dock. The dock only has the standard icons plus Word, Excel, PowerPoint, and her Mail client.

Since I'm sure there's no special background apps starting up when she logs in, I'm left to wonder if there's a cache that is being read that may be corrupted that's delaying everything. Does anyone have any idea what the names of the caches are that may be involved following the login process? Even though I'm sure the caches aren't fragmented (the problem persisted both before and after defragmenting), they may be damaged, and I'd like to delete them to force the OS to rebuild them.

I'm really quite puzzled at this point, since there's no delay at all when logging into the only other account on this machine (Administrator). I don't really want to create a new account for her and move all her data over to it just to fix this issue, but will if I have to.

Thanks for listening... :confused:
you repair permissions yet? any network drives?
 
Comment

Dave Marsh

macrumors regular
Original poster
Jul 23, 2002
210
0
Sacramento, CA
Hi again, I've repaired permissions a couple of times with no further benefit. The issue about fonts intrigues me, however. I'll look for stuff in her user Library area, since the Administrator account works fine.

Thanks for the fine article reference. I'm excited to try it. :)
 
Comment

Dave Marsh

macrumors regular
Original poster
Jul 23, 2002
210
0
Sacramento, CA
Problem Solved

The fonts cache solution seems to have worked. Specifically, I followed this advice:

"You can do this manually by finding and removing these files:
In /System/Library/Caches:
fontTablesAnnex
(fontTablesAnnex contains the character encodings/mappings for all of the fonts on your system. Information in this file can lead to garbled text.)
com.apple.ATS.System.fcache
com.apple.ATSServer.FODB_System
In /Library/Caches:
com.apple.ATS
In your home directory’s Library/Preferences folder:
com.apple.ATS.plist

In my case, the problem was solved by trashing /System/Library/Caches/fontTablesAnnex. None of these cache files are essential, however, so I deleted them all. (The “com.apple.ATS.plist” prefs file, on the other hand, tracks, among other things, the disabled fonts you’ve specified using Font Book. I left this in place.)"

Thanks for the timely and useful feedback, people. :D
 
Comment

BWhaler

macrumors 68030
Jan 8, 2003
2,923
3,124
Cleo's advice is spot on. It's a terrible bug in Panther. Hopefully it is fixed in Tiger.
 
Comment

Similar threads

  • iemcj
10
Replies
10
Views
1K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.