SIGSEGV Spotlight - mdworker_single 0% CPU

Discussion in 'macOS Mojave (10.14)' started by mspm123, Dec 9, 2018.

Tags:
  1. mspm123 macrumors newbie

    mspm123

    Joined:
    Dec 9, 2018
    #1
    My new MacBook Pro 2018 8 core on Mojave has some issues generating a proper Spotlight database. I tried the obvious methods of excluding the drive, re-including it, and the terminal commands for rebuilding Spotlight. Additionally I ran Disk Utility First Aid twice, which automatically restarted my machine each time during process (?!)

    These are the constant errors coming up in system log, they are thrown around every second.

    Dec 6 23:25:46 MacBook-Pro com.apple.xpc.launchd[1] (com.apple.mdworker.single.0A000000-0000-0000-0000-000000000000): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
    Dec 6 23:25:49 MacBook-Pro com.apple.xpc.launchd[1] (com.apple.mdworker.single.09000000-0000-0000-0000-000000000000[4085]): Service exited due to SIGSEGV | sent by exc handler[4085]

    When searching with Spotlight, the "Indexing" bar is constantly showing up, never progressing significantly. Some days later, still there.

    I double clicked one of the mdworker_shared Process Names in Activity Monitor and clicked the tab "Open Files and Ports" which revealed this:

    cwd
    /
    txt
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Support/mdworker_shared
    txt
    /Library/Preferences/Logging/.plist-cache.XLHIwKkt
    txt
    /usr/share/file/magic.mgc
    txt
    /System/Library/Spotlight/Image.mdimporter/Contents/MacOS/Image
    txt
    /private/var/db/timezone/tz/2018g.1.0/icutz/icutz44l.dat
    txt
    /private/var/folders/7l/6j3svjhs13l39y6f96hmw_j40000gq/0/com.apple.LaunchServices-231-v2.csstore
    txt
    /usr/lib/dyld
    txt
    /usr/share/icu/icudt62l.dat
    0
    /dev/null
    1
    /dev/null
    2
    /dev/null

    Some other mdworker_shared processes reveal some open files which remain the same even after double-clicking the mdworker_shared process again.

    It is significant that all mdworker_shared processes run at 0% CPU - they do not index at all.

    I did all the normal reindexing:
    sudo rm -rf /.Spotlight-V100/*
    disable, enable spotlight

    I checked for hardware errors with AHT already.

    Whats the catch?

    Guesses
    1. Issue indexing the .DS_Store files?
    2. Access error?
     

Share This Page