Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iPhone Silence All Text Message Sounds During "Do Not Disturb" Scheduled Time

Gmouse

macrumors 6502
Original poster
Nov 12, 2014
299
62
Lakewood, CO
My wife has iPhone 8, latest iOS 13.5.1, and Do Not Disturb is set from 2100 to 0600. However, each morning at 0500 and from multiple phone numbers she gets a Covid-19 Health Questionnaire from her work texted to her, and this always plays her normal text sound...waking us up. The text doesn't contain the word "Urgent" or anything that should override the setting and comes from multiple phone numbers, and we don't want to block each of them individually, just need ANY text message sound to NOT play during the Do Not Disturb scheduled time, but DOES play at all other times. How to make this happen?

Thanks!
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
50,828
19,018
Messages should not be breaking through Do Not Disturb. As I recall the only exception would be if they are from an Emergency Contact.

Are you certain that Do Not Disturb is in fact active at that time? Have you checked the DND settings to confirm and perhaps disable/re-enable them just in case?
 
  • Like
Reactions: Rhonindk
Comment

C DM

macrumors Sandy Bridge
Oct 17, 2011
50,828
19,018
Check what you have set in Favorites also. These come through on mine.

Also check your work hours especially if you have any Device Management installed.
As I recall you can have DND set up where calls come through from Favorites (or Contacts, or even more than that), but I don't believe that applies to messages or basically any other apps or notifications aside from calls.
 
  • Like
Reactions: compwiz1202
Comment

Gmouse

macrumors 6502
Original poster
Nov 12, 2014
299
62
Lakewood, CO
Messages should not be breaking through Do Not Disturb. As I recall the only exception would be if they are from an Emergency Contact.

Are you certain that Do Not Disturb is in fact active at that time? Have you checked the DND settings to confirm and perhaps disable/re-enable them just in case?
Thanks. Not an Emergency Contact (or even listed in Contacts)--different phone numbers. Verified DND is still on until 0600 and messages come in at 0500--not a Time Zone issue, either as source and target all in same location.
[automerge]1592254844[/automerge]
Check what you have set in Favorites also. These come through on mine.

Also check your work hours especially if you have any Device Management installed.
Not a Favorite. Thanks!
 
Comment

compwiz1202

macrumors 68030
May 20, 2010
2,697
1,473
As I recall you can have DND set up where calls come through from Favorites (or Contacts, or even more than that), but I don't believe that applies to messages or basically any other apps or notifications aside from calls.
Yea if anything, I have the issue where I only get calls from Favs but no messages if DND is on.
 
Comment

Rhonindk

Contributor
As I recall you can have DND set up where calls come through from Favorites (or Contacts, or even more than that), but I don't believe that applies to messages or basically any other apps or notifications aside from calls.

Maybe however my Pro Max on 13.5 - calls and messages from the few in my favorites do ding or ring thru.
I’ll need to play with this and make sure ...
I’ll have a couple folks on my Fav test this out tonight ...

Update: It could be because Emergency Bypass (under Text Tone) is on for some Contacts in my Favorites ... That is supposed to allow bypassing DnD
 
Last edited:
Comment

C DM

macrumors Sandy Bridge
Oct 17, 2011
50,828
19,018
Maybe however my Pro Max on 13.5 - calls and messages from the few in my favorites do ding or ring thru.
I’ll need to play with this and make sure ...
I’ll have a couple folks on my Fav test this out tonight ...

Update: It could be because Emergency Bypass (under Text Tone) is on for some Contacts in my Favorites ... That is supposed to allow bypassing DnD
Yeah, the emergency options will generally allow for DND bypass (for calls and messages).
[automerge]1592259881[/automerge]
Thanks. Not an Emergency Contact (or even listed in Contacts)--different phone numbers. Verified DND is still on until 0600 and messages come in at 0500--not a Time Zone issue, either as source and target all in same location.
[automerge]1592254844[/automerge]

Not a Favorite. Thanks!
This is kind of and odd one. Is the phone locked at the time when the messages come in?
 
Comment

Rhonindk

Contributor
Maybe however my Pro Max on 13.5 - calls and messages from the few in my favorites do ding or ring thru.
I’ll need to play with this and make sure ...
I’ll have a couple folks on my Fav test this out tonight ...

Update: It could be because Emergency Bypass (under Text Tone) is on for some Contacts in my Favorites ... That is supposed to allow bypassing DnD

Update:
Did some testing last night (Pro Max on 13.5) with DnD active:
1 - Contacts in my Favorites calls rang through
2 - Contacts in my Favorites texts did not ring through
3 - Contacts in my Favorites with Emergency Bypass set texts did ring through.
 
  • Like
Reactions: C DM
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.