Silverlight doesn't work but is installed

Discussion in 'OS X Mountain Lion (10.8)' started by bwiggin, Dec 20, 2012.

  1. bwiggin macrumors newbie

    Joined:
    Dec 20, 2012
    Location:
    South Carolina
    #1
    i am having major issues with silverlight. i have reinstalled it multiple times and uninstalled it completely multiple times. Netflix does not work in any browser and the main reason i need it fixed is for a program that i use named Fender Fuse that uses silverlight. when i open fender fuse, it loads and then i get stuck with a black screen. when i close it a quit unexpectedly crash log pops up.

    [​IMG]

    [​IMG]

    [​IMG]

    when trying to watch anything on Netflix when i click on any thing to watch i get a spinning loading screen. when i right click and select silverlight preferences it crashes right away.


    [​IMG]

    [​IMG]

    [​IMG]

    No matter how many times i uninstall and reinstall any version of silverlight it does this. i have attempted many times to remove everything that had to do with silverlight all of the plugins and receipts but its the same every time. I can post the entire error log if needed if someone things they can solve it. i would like to fix this issue without reinstalling ML. thanks in advance for your help.
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    First off, this post is based on my experience with a 2009 MacBook Pro running OS X 10.8.2 and Silverlight 5.1.10411.0. On this computer, I installed Fender FUSE Version 2.6.0.25.

    It sounds like you never properly installed Fender FUSE. Doing so is no mean feat. The Mac version of Fender FUSE is a Mono frameworks-based port of the .NET-based Windows version. Fender never updated the installer to Gatekeeper-compatibility. Once installed from the mounted disk image, however, Fender FUSE appears to operate as intended.
     
  3. Kungshi macrumors member

    Joined:
    May 11, 2011
    #3
    I'm having the same problem with Netflix telling me I need to install an already installed Silverlight. Could you check and see if any browsers are or are not playing video? Try hulu and CBS for me. I can't get any of those to play. I also cant establish a connection for updates to the Mac App Store even though my iTunes is telling me there is an update available. Please let me know if you or anyone else is having these same troubles.
     
  4. bwiggin thread starter macrumors newbie

    Joined:
    Dec 20, 2012
    Location:
    South Carolina
    #4
    i have reinstalled both several times and the problem doesn't change.i have tried to remove silverlight and install silverlight through the fender fuse installer but that didn't help either. is there something im missing? deleting everything that has to do with silverlight and then reinstalling does not work.
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    You have posted screen shots. You have stated that you have a problem. You have described a process of deleting stuff willy-nilly. You have said that you reinstalled the stuff that you deleted willy-nilly.

    On my nearly four-year-old MBP, Fender FUSE works as intended. But then, I did not toss-in a grenade when I ran into a problem. You need to describe exactly how you deleted what.
     
  6. bwiggin thread starter macrumors newbie

    Joined:
    Dec 20, 2012
    Location:
    South Carolina
    #6
    by deleting silverlight from /Library/Internet Plug-Ins/

    i followed someone else's advice (kinda) and found all the silverlight files in "Invisible Files".
    In the Finder, choose File > Find or press Command (⌘)-F.
    From the far-left pop-up menu (labeled “Kind”), choose Other.
    In the list of search attributes, select the “File invisible” checkbox, and then click OK.
    In the related menu, choose Invisible Items.
    once loaded go to folder Private
    then to folder VAR
    then folder db
    theb folder Receipts
    scroll to any com.microsoft.silverlight item and delete. there are a bunch of them.
    close, restart and install silverlight.
     

Share This Page