Silverlight not working

Discussion in 'OS X Yosemite (10.10)' started by Tex-Twil, Jan 24, 2015.

  1. Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #1
    Hi,
    I made a fresh installation of Yosemite but now Silverlight is not working in my browsers. I tried Safari, Firefox and Chrome. I also tried removing the /Library/Internet Plug-Ins/Silverlight.plugin file and reinstalling Silverlight.

    The page is all the time showing me "Install Silverlight" :mad:

    http://www.microsoft.com/silverlight/iis-smooth-streaming/demo/

    any ideas ?
     
  2. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #2
    I might be wrong, but I seem to recall that Silverlight is on life-support now.

    MS is not actively working on it, just bug fixes. Chrome will be dropping support for it in April(?) for all platforms. They've already dropped it for OS X for v39+.

    Latest version for Mac looks to be pre-Yosemite, so, would not be surprised it's not working. Last released version of Silverlight for Windows is 5.1.31211.0 while Mac is 5.1.30514.0. So, I'm inferring, MS has stopped working on Mac version.
     
  3. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #3
    I forgot to mention that I had Yosemite before and Silverlight was working in Safari.

    I know that Chrome has problems with it but Safari was working fine.
     
  4. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #4
    Isn't there a workaround ? Why was it working on the same mbp on Yosemite before I reinstalled and not now?
     
  5. Thunderboltedge macrumors regular

    Thunderboltedge

    Joined:
    Nov 12, 2014
    Location:
    Milan
    #5
    For me it happened only on Chrome that it was working as it was, then after a fresh installation it was not working anymore.

    I gathered information and I realized that the Chrome version I was using after the fresh installation was the 39, the latest, which had already dropped the Silverlight support so it was not capable anymroe to run on it.

    For the other browsers indeed nothing changed at all, they still support it both Safari and Firefox
     
  6. Tex-Twil thread starter macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #6
    Yes I was also using Chrome before, then switched to Safari since Chrome stopped supporting Silverlight.

    I solved the problem by copying the Silverlight.plugin from my backed up hard disk. It's located in /Library/Internet Plug-Ins/Silverlight.plugin and its version seem to be 5.1.30514.0

    cheers
     
  7. morgansbob macrumors newbie

    Joined:
    Jan 24, 2016
    Location:
    North Notts.
    #7
    Hi Tex-Twil, I had the same issue and started a thread. Before I got an answer I managed to get Silverlight installed. The only thing that I did different was to disable the firewall until it was installed.

    Good luck
     

Share This Page