Silverlight Plugin Crashes Safari (every time)

Discussion in 'Mac Apps and Mac App Store' started by MBHockey, Aug 13, 2008.

  1. MBHockey macrumors 68040

    MBHockey

    Joined:
    Oct 4, 2003
    Location:
    New York
    #1
    I am trying to watch the video highlights from the olympics over at nbcolympics.com

    I installed the MS Silverlight plugin on three different Intel Macs (Mac Mini, MacBook, MacBook Pro) all running Leopard and the latest Safari, but every time I try to watch a video (without fail), Safari crashes.

    Is this working for anyone else?

    Edit: It's being caused by AdBlock. Just disable AdBlock if you are getting this crash in Safari and then reload the video.
     
  2. amoney macrumors newbie

    Joined:
    Aug 16, 2008
    #2
    Thanks for the tip! I was running into the same issue. BTW, if you want to leave AdBlock running but would like to see the olympics highlights, add the following custom filter in AdBlock:

    Don't block anything on pages whose URL starts with http://www.nbcolympics.com

    Obviously this only help for Silverlight content on the NBC Olympics page, but so far I haven't found any other need for the plugin. :p
     
  3. monoguy54 macrumors newbie

    Joined:
    Mar 12, 2005
    Location:
    Canton OH
    #3
    Silverlight won't run?

    I downloaded/installed "successfully" silverlight V1.0 (I have a PPC and Tiger), however it doesn't seem to run.
    when I'm using Safari instead of activating the plugin, it just opens a window that has a "install silverlight plugin" link (I've already installed it).
    In Firefox 2 it opens a a "blank window" that indicates it is "transferring data from all-access.cbssports.com" but it just sits there.

    I don not have AdBlock

    any ideas? I am trying to watch ND football video links from the athletic website
     
  4. shareef777 macrumors 68000

    shareef777

    Joined:
    Jul 26, 2005
    Location:
    Chicago, IL
    #4
    Sorry to revive such an old thread, but does anyone else still experience this issue? Silverlight crashes in every browser that I use.
     
  5. Invizzible macrumors regular

    Joined:
    Feb 9, 2003
    #5
    It worked fine for me for a long time. Now suddenly, it will freeze my entire computer while I'm watching a Netflix streaming movie. I have to do a hard reset with the power button, and when I try to go back to the Netflix movie I get a screen that tells me I have to uninstall and reinstall Silverlight. Already did that once, and it worked for about a day, then locked up again and now tells me to do the uninstall/reinstall again. Anyone know what's going on?
     
  6. klendathu macrumors newbie

    Joined:
    Aug 26, 2011
    #6
    Safari, Silverlight, Intel Mac

    We have an application that requires Silverlight that works flawlessly on an Intel Macbook in Firefox, but in Safari, it just won't work. I've gone to the Silverlight website, and it confirms that in safari we have the latest version of Silverlight installed, but the app won't launch. Using OS 10.6.8, Safari 5.1.

    Any ideas would be appreciated.

    We've already tried: turning rosetta on, or off. Enabling 32-bit mode in Safari, reinstalling Silverlight.

    Klendathu
     
  7. gboswellsac macrumors member

    Joined:
    Apr 3, 2010
    Location:
    San Antonio TX
    #7
     

Share This Page