Sim card tray eject problem with Rebel Sim

Discussion in 'Jailbreaks and iOS Hacks' started by nickafc1903, Oct 1, 2008.

  1. nickafc1903 macrumors newbie

    Joined:
    Aug 29, 2008
    #1
    Hi there

    just put a Rebel Sim into iPhone 3G with Vodaphone sim card. Rebel Sim worked a treat and very happy with it but on trying to eject sim card holder, the holder does not pop up. Thankfully has put some tape on so can remove holder but would rather not have tape showing for cosmetic reasons. has anyone else encountered a problem like this. it seems like the eject mechanism is totally knackered. Is this replaceable. Any help would be appreciated
     
  2. hatedorloved macrumors newbie

    Joined:
    Sep 12, 2008
    #2
    i had it aswel that it didnt want to eject the sim i used a small screw that fits in the little hole to pul it out didnt liked the idea that it didnt work anymore restored to original inserted a pay and go o2 sim in and did go to applestore and told my sim didnt wanna come out anymore guy uses screwdriver to get o2 sim out and got a new iphone 3g that works fine with yessim on orange
     
  3. LeoLohan macrumors newbie

    Joined:
    Sep 24, 2008
    #3
    ReBeL Sim carD

    i have spend many money in buying these sims to unlock my iPhone to spain network , The only last solution that worked on my iPhone is Rebel sim card , altough i use tape as they tell it before selling their product in their support chat , but with tape i never faced getting problem getting the sim out , the thing i like most in this product is their live help support , before or after buying the product . . . if you face any problem regarding your sim , Rebel sim or any other thing they solve it online via their support chat . . . visit their site. . . . www.rebelsimcard.com
     

Share This Page