SimCity 4 Deluxe on Boot Camp

Discussion in 'Windows, Linux & Others on the Mac' started by adam1185, Apr 19, 2006.

  1. adam1185 macrumors regular

    Apr 30, 2004
    I just installed Sim City 4 Deluxe on Windows on my 20" iMac and it runs like crap. Everytime you try to move around on the map it just stutters horribly. Has anyone else installed this game on windows yet? All the other games I have installed work perfectly yet this is just terrible performance.

  2. adam1185 thread starter macrumors regular

    Apr 30, 2004
    Well that didn't take long. It seems you need to set simcity 4 to render in software mode in the option and now it works great.
  3. atmenterprises macrumors 6502

    Jan 28, 2006
    I tried installing it on my XP partition thru BootCamp and it hung up on the second CD. So I gave up and am about to drop the BootCamp and just run Parallels.
  4. naquadah1 macrumors newbie

    Mar 12, 2009
    i am trying to install Sim City 4 Deluxe through Boot Camp with WIndows Xp SP3. I have a MacBook Pro 2.4Ghz Intel. but there i get an error in the install progress. the error says "Error executing 'D:\Support\SimCity 4 Deluxe_uninst.exe' Only part of a ReadProcessMemory or WriteProcessMemory request was completed."

    has anyone seen that?

Share This Page