Simple question about updating my Macbook.

Discussion in 'MacBook' started by Gnar-kill, Jan 21, 2013.

  1. Gnar-kill macrumors newbie

    Joined:
    Jan 21, 2013
    #1
    I just bought an Iphone 5 and try to plug it in to the computer, computer tells me the iphone requires itunes 10.7. I think this is a misscript and it actually means that the software is out of date on the computer. I did some research on here and have come up with i need 10.6.8 on my computer. I am not sure if i need a new computer or if this computer is even capable of downloading the newer os. I will list what my computer is, and if someone would tell me what is the best route, or if i need a newer mac...then it would be greatly appreciated. Thanks in advance.

    Hardware Overview:

    Model Name: MacBook
    Model Identifier: MacBook3,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 2 GB
    Bus Speed: 800 MHz
    Boot ROM Version: MB31.008E.B02
    SMC Version (system): 1.24f3
    Hardware UUID: 537DD8CC-51C2-5234-94AF-E78CA658DACA
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Snow Leopard will run fine on that machine. You can even run Lion on it. But I suggest upgrading the ram to 4GB if you want to run Lion.
     
  3. Gnar-kill thread starter macrumors newbie

    Joined:
    Jan 21, 2013
    #3
    So all i need to do is purchase snow leopard? The guy at apple support told me this machine was currently running it. I dont want to change the computer around at all..
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    Click on the Apple menu in the top left of your screen and click on About this Mac. In the window that opens you should see it say either 10.5.8 or 10.6.8. What does it say?
     
  5. Gnar-kill thread starter macrumors newbie

    Joined:
    Jan 21, 2013
    #5
    Sorry i forgot to mention that. 10.5.8...
     
  6. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #6
    You have Leopard on that machine. You'll have to get Snow Leopard for that machine.
     
  7. Gnar-kill thread starter macrumors newbie

    Joined:
    Jan 21, 2013
    #7
  8. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #8
    Yes that is what you need. You don't have to backup your data. Snow Leopard can upgrade your current OS to 10.6 without you loosing your stuff. But it never hurts to always have a good backup around.
     
  9. Gnar-kill thread starter macrumors newbie

    Joined:
    Jan 21, 2013
    #9
    In other words i upgrade to this and then my itunes will work with the free update to 6.8? Also they no longer have a downloadable version of this? From what i understand...
     
  10. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #10
    Yes, you can still download the 10.6.8 combo update for Snow Leopard and iTunes 10.7 and iTunes 11.
     

Share This Page