Sims 2 Issues

Discussion in 'Mac and PC Games' started by iMacUser-21, Mar 7, 2008.

  1. iMacUser-21 macrumors newbie

    Joined:
    Feb 14, 2008
    #1
    Hello,
    I have been recieving some issues with playing Sims 2 on my iMac. The problem is that when I am playing it, Part of the house , roads etc go all blue.
    Below are the specs of my iMac and all help is appreicated.

    2.0GHz
    Intel Core 2 Duo
    1GB memory
    250GB hard drive

    Oh and if you need any more information please ask..

    :apple:
     
  2. wgilles macrumors 6502

    wgilles

    Joined:
    Feb 21, 2008
  3. Rick Ward macrumors newbie

    Joined:
    Nov 15, 2007
    Location:
    Lincoln UK
    #3
    I'm assuming it's an Aluminium iMac with the ATI HD2400 graphics card as this model will give the results you are getting when playing the Sims 2.

    The original version of the Sims 2 and all the expansion packs (except Bon Voyage) do not work on your graphics card. (They will work on the HD2600 fitted to higher models though).

    We had the same problem and the only way to get it working that I am aware of is to buy the Bon Voyage expansion pack that was released in December 07, as it supports the latest graphics cards, and also you must make sure you have "optimised rendering" turned off in the options, otherwise you will still get the blue patches.
    Ours works perfectly now with excellent graphics.

    It might be worth checking on Aspyr's web site to see if there are any updates released after December 07 that solve the problem first.
     
  4. iMacUser-21 thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #4
    so i turn off "optimised rendering" in options and I will stop getting the blue patches?
     
  5. Techguy172 macrumors 68000

    Joined:
    Feb 2, 2007
    Location:
    Ontario Canada
    #5
    Yes but check for updates first.
     
  6. Rick Ward macrumors newbie

    Joined:
    Nov 15, 2007
    Location:
    Lincoln UK
    #6
    Have you installed the Bon Voyage expansion Pack? If so then turning off Optimized Rendering should work.
    To turn off optimised rendering hold the Apple/Command key while launching the game to get in to the Advanced Options menu. Then click off "Optimized Rendering".

    If you haven't installed Bon Voyage, I have checked apsyr's website and there is an update that MIGHT fix your problem. It's certainly worth a try first.
    To download the update go to:-
    http://www.macgamefiles.com/detail.php?item=18775

    There are 2 versions of the update, a Combo Patch and a Rev F Patch. I suggest you use the Combo Patch as it will install all the previous updates too, to bring your game right up to date.
    If installing the update and turning off "Optimized Rendering" doesn't work I think you will need to buy and install Bon Voyage.
     
  7. Mercuric Oxide macrumors 6502

    Joined:
    Jan 6, 2008
    Location:
    NYC
    #7
  8. grngirl macrumors newbie

    Joined:
    Mar 24, 2008
    #8
    Advanced Options

    I do not understand how to open the advanced options. I tried holding the apple/command key while the game was loading and nothing ever happens. Is there a specific timing or something that i need to hit the key to have the advanced options pop open. Im very confused.
     
  9. estee065 macrumors member

    Joined:
    Jun 26, 2006
    #9
    don't open it from the dock. Double click the icon from the finder window while holding the command key.
     
  10. fatcat99 macrumors newbie

    Joined:
    Mar 25, 2008
    #10
    Yeah I'm having a problem doing the advanced options too. I tried it in the dock and the finder several times and the advanced options window has never popped up.
     
  11. iMacUser-21 thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    #11
    Sorry I havent replied
    It works now and I had no problem accessing advanced options using the dock icon.

    :apple:
     

Share This Page