Sims 3 Authentification Failure

Discussion in 'Mac and PC Games' started by my2geldings, Jan 3, 2011.

  1. my2geldings macrumors member

    Joined:
    May 31, 2010
    #1
    I've played this game day in and day out and this morning when I turned it on, and would attempt to start the game, it would tell me the following:

    ________________________
    Disc Authentication Failure
    No game disc found! Insert The Sims 3 game disc before proceeding.
    ________________________

    I've tried quitting the game and restarting. Ive tried inserting the game in different times, but I always get the same message. Is there any way to save this? I have thought of removing the game from the computer, and just re-installing it, tho I have no idea how to do that-but not sure it would make a difference. Im not computer savvy unfortunately.

    Anyone else have had this?
     
  2. PatrickCocoa macrumors 6502a

    Joined:
    Dec 2, 2008
    #2
    A few things

    1. Sims 3 updates itself. It's possible you updated with or without knowing it, and the new version is causing this.

    2. It may be caused by a bug in the new version, or possibly the new version is picking up (correctly or incorrectly) that you're pirating it (or have some no-CD crack).

    3. Call or e-mail the manufacturer. The only way (long term) to get companies to fix their problems is to make them incur costs (in this case support costs). Then they'll try to make software that doesn't require heavy support costs. /utopia mode ON: maybe they'll even make good software that doesn't break /utopia mode OFF.
     
  3. Blair230 macrumors regular

    Joined:
    Feb 17, 2009
    Location:
    Near Philly
    #3
    THere was an issue like this when it was first released but that has been resolved in subsequent updates. Make sure you have the original DVD in the drive when playing. If you do, then your best bet would be to email the SIMS support or search through the Sims3 forums. Here is a thread in those forums discussing the issue:

    http://forum.thesims3.com/jforum/posts/list/32201.page

    Good Luck! :apple:
     

Share This Page