Sims 3 Gen Not Opening! :'(

Discussion in 'Mac and PC Games' started by mel87v, Jun 1, 2011.

  1. mel87v macrumors newbie

    Joined:
    Jun 1, 2011
    Location:
    Chicago, Illinois
    #1
    I just downloaded The Sims 3 - Generations for my MacBook Pro...install and everything went smoothly (at least I think...), but now when I go to open the game to play, the Sims 3 icon bounces...then it changes to the Generations icon, and then both disappear and nothing happens.

    Help?

    Hardware Overview:

    Model Name: MacBook Pro
    Model Identifier: MacBookPro8,2
    Processor Name: Intel Core i7
    Processor Speed: 2 GHz
    Number of Processors: 1
    Total Number of Cores: 4
    L2 Cache (per Core): 256 KB
    L3 Cache: 6 MB
    Memory: 4 GB
    Boot ROM Version: MBP81.0047.B0E
    SMC Version (system): 1.69f1
    Serial Number (system): C02F8HKPDF8V
    Hardware UUID: BC232ABB-A076-5483-9EE0-68EC38323C06
    Sudden Motion Sensor:
    State: Enabled
     
  2. megw06 macrumors newbie

    Joined:
    Jun 1, 2011
    Location:
    New York, NY
    #2
  3. Magz macrumors newbie

    Joined:
    Jun 2, 2011
    Location:
    Manchester, UK
    #3
  4. Ladybug macrumors 65816

    Ladybug

    Joined:
    Apr 13, 2006
    #4
    After playing the Generations successfully for about a week, my game stopped running too. After several reinstalls and cleaning out the cache folder with no luck, I ran across a post that instructed to go to

    user/library/the sims 3 preferences
    then find and delete "system.reg" file.

    After deleting this one file, my game was up and running again. It seems this file is getting corrupted somehow. Posting this in case someone else runs into this issue too.
     

Share This Page