Sims 3 installation problems.

Discussion in 'Mac and PC Games' started by rebecca.x, Mar 27, 2010.

  1. rebecca.x macrumors member

    Joined:
    Jul 21, 2009
    #1
    So frustrated at the moment, hopefully someone can help me. Ive searched the forum and found this question before but with no solution, but hopefully I can find one this time.

    In short Ive searched on the net for a solution for the past two days and now I'm at the process of tearing my hair out. I cannot get the sims 3 to install on my 17 inch (not even a year old) macbook pro. My housemates 13 inch macbook can run this game but for some reason my macbook seems incapable. I meet all the system requirements but during installation it keeps getting stuck on 468 (or something similar) out of X installed, with 14 minutes remaining. Ive tried installing four times now, one in a different location to the others to no avail. I really have no idea what to do. :/ I just dont understand how my machine is incapable of installing it but my housemates macbook installed it fine.

    Any help is greatly appreciated : )
    Rebecca
     
  2. robotkitsch macrumors newbie

    Joined:
    Apr 23, 2010
    #2
    I'm having exactly the same problem with mine, even to the number of the file at which the installer freezes.

    I booked an appointment at my local genius bar and I'm going to see what they say about it all.

    Kitty.x
     
  3. evaughan10 macrumors newbie

    Joined:
    May 4, 2010
    #3

    Hey I was wondering if you got any help because my Macbook Pro is doing the exact same thing stuck on file 486 out of 517 and it is so frustrating!
     
  4. evaughan10 macrumors newbie

    Joined:
    May 4, 2010
    #4
    Solution Found!

    Hey guys, so I called up EA support and he said if it is doing this repeatedly (cos I had tried to install it 4 times and it got stuck in the same place) then there is something wrong with the disc. I took my disc to my local video shop and they have a cleaning machine that costs $5 and it solved the problem.
    Why it does this to Macs? Im not sure, maybe Macs have an ultra sensitive disc drive, but give my idea a try and see if it helps. :)
     
  5. dontcallmyname macrumors member

    Joined:
    Jun 18, 2010
    #5
    so getting the disc cleaned works? gahh! I'm having the same issue but it's getting stuck on file 3. I was fairly sure my disc needed to be cleaned as i'm having some issues with it :p

    le sigh, i'll have to see if cleaning works

    EDIT: I did a quick clean of it myself (not the first I've tried on this disc but definitely the best) and got it past file 3 and now it's stuck on 486 with 12 minutes to go. i'm not sure how long it's been like that as i've been doing something else, but i'm going to wait and see if it passes. I am moving some huge videos between hard drives at present, so that might be a factor. If it doesn't resolve itself, i may try cleaning it myself again, else i'll track down a video store. I'm thinking that it might be progressing because now it's at 8 minutes.

    SUCCESS! It's progressed to to file 487. heres to hoping the rest is speedy!
     
  6. ninahcotton macrumors newbie

    Joined:
    Jul 2, 2012
    #6
    I did this

    I had this.
    My disc was too scratched so I used a friends. And then it worked. So it could be that or your drive is messed up. Better to find a new/cleaner disc first before getting your macbook booked in.
     
  7. marieweaver132 macrumors newbie

    Joined:
    May 7, 2012
  8. errrrrrrica macrumors newbie

    Joined:
    Mar 20, 2013
    #8
    but mine's a download

    I'm having the same problem. I get stuck at 837 out of 889 but I have a downloaded copy I bought through origin.com. Cleaning obviously won't help me. What's the deal?
     
  9. stampedez macrumors newbie

    Joined:
    Mar 25, 2013
    #9
    I fixed my digital download was stuck

    hi, i made this profile as i have fixed mine today after days of trying, i had a digital download though origin so if you need help i will explain over the phone or by Skype/xbox chat, my email is: stampedez13@gmail.com send me a email and i will show you how i fixed mine. thanks. Jon
     
  10. tnawara macrumors newbie

    Joined:
    Jun 9, 2008
    #10

    We're having almost exactly the same problem, although ours gets stuck at 840 of 889 with the digital download. Has anyone been able to figure out a solution?
     

Share This Page