Sims 3 on 2.4 uMBP lagging severely, even on lowest settings

Discussion in 'Mac and PC Games' started by Advil, Jun 23, 2009.

  1. Advil macrumors 6502a

    Joined:
    Oct 4, 2008
    #1
    Hey all. I have a unibody Pro, 2.4ghz, 4 gigs of ram and using the "best performance" setting in the energy saver preferences to use my good GPU and I get extremely low framerates in The Sims 3. My girlfriend loves this game and it runs like crap on her macbook so I let her install it here and I feel bad because it runs, but extremely slowly.

    I tried changing the graphical settings from the default maxed out options to medium, then after not seeing any improvement I put the settings ALL on low and turned off the advanced shaders and reflections, the bare minimum, and still got 15 frames per second maximum when zoomed out, then when zoomed in on my characters I got 5-7 fps these are the same exact speeds I got at max settings. I tried removing the game and all traces of it and reinstalling and still have the same result. Then I tried blasting the fans to keep the gpu/cpu temps down and still no luck.

    Also there are NO apps running in the background during gameplay. I always have my computer on "better battery life" and switch on the GPU just to play so it logs out, and when I log in I make sure nothing is running before starting up the game.

    Any input, ideas or solutions?

    Thanks in advance!
     
  2. colonels1020 macrumors regular

    colonels1020

    Joined:
    Mar 9, 2006
    #2
    Well, from the sound of your post, it sounds like you're running Windows. Check out the nVidia website for the latest graphics driver and see if that helps out your gaming performance. :)
     
  3. admanimal macrumors 68040

    Joined:
    Apr 22, 2005
    #3
    What exactly in his post made you think he is running it in Windows?

    I have a new 2.66GHz uMBP and it runs the game fine using either the 9400 or 9600 GPUs (obviously better with the latter). With the 9600 I can turn the settings to the higher side of medium and it runs perfectly smooth. This is all in OS X, of course.
     
  4. Advil thread starter macrumors 6502a

    Joined:
    Oct 4, 2008
    #4
    What resolution do you run at? I tried all of them and still nothing.

    I'm running 10.5.7. Just got my mac like two days after that update came out and i'm never using windows again.



    ever.
     
  5. hotness123 macrumors newbie

    Joined:
    Jun 24, 2009
    #5
    well it could be the fact that you have a weaker graphics card than the user with the 2.66 mbp. even on 9600 nvidia its only 256 as opposed to 512 for the last gen models. hope that helps.
     
  6. admanimal macrumors 68040

    Joined:
    Apr 22, 2005
    #6
    I don't remember exactly...I just tried it once for a while after getting the new computer. I'll try it again now that I have a cinema display with higher resolution.
     
  7. gavriels macrumors newbie

    Joined:
    Sep 6, 2007
    #7
    Check to make sure that you don't have another program running that's using all of the CPU. Sometimes Safari can get stuck on a page with lots of JavaScript and suck out an entire CPU core. The Sims 3 is a very CPU heavy game due to the simulation involved, and needs as much CPU available as possible.

    You can use the Activity Monitor (in /Applications/Utilities) to see what processes are taking up CPU.

    The other thing to try is to reboot your system. Sometimes a software issue at the driver level (Graphics channel reset) can cause graphics performance to drop substantially until you reboot.
     

Share This Page