Since going to 4.2.1 inter-app switching crashes Springboard

Discussion in 'Jailbreaks and iOS Hacks' started by eelpout, Dec 2, 2010.

  1. eelpout macrumors regular

    eelpout

    Joined:
    Oct 30, 2007
    Location:
    Silicon Valley
    #1
    After having installed 4.2.1 with the latest PwnageTool, everything appears to work except inter app switching on my 3G. Now Springboard crashes every time an app tries this (i.e. Yelp trying to open Maps for directions)

    Below is a log of a caught crash. I bolded the exception, which I'll have to research a bit.! It almost seems like Springboard/iOS doesn't think I'm running a 3G because of the color reference. Anyone have any ideas? :confused:


    Code:
    ## syslog
    Dec 2 11:41:20 my-iPhone SpringBoard[883]: *** Assertion failure in -[SBAppDosadoView initWithFrame:], /SourceCache/SpringBoard/SpringBoard-1288.40/SBAppToAppTransitionView.m:46
    Dec 2 11:41:20 my-iPhone SpringBoard[883]: [B]*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'SBAppToAppTransitionView should only be used on devices with fast color multiply'\n***[/B] Call stack at first thrown(\n 0 CoreFoundation 0x3759dc7b __exceptionPreprocess + 114\n 1 libobjc.A.dylib 0x32d9bee8 objc_exception_throw + 40\n 2 CoreFoundation 0x3759dac3 +[NSException raise:format:arguments:] + 70\n 3 Foundation 0x351a3e73 -[NSAssertionHandler handleFailureInMethodbject:file:lineNumber:descr iption:] + 62\n 4 SpringBoard 0x00105875 0x0 + 1071221\n 5 SpringBoard 0x0010d439 0x0 + 1102905\n 6 SpringBoard 0x00013c4f 0x0 + 80975\n 7 SpringBoard 0x00013009 0x0 + 77833\n 8 SpringBoard 0x0001e659 0x0 + 124505\n 9 SpringBoard 0x0004adf3 0x0 + 306675\n 10 SpringBoard 0x0001aecb 0x0 + 110283\n 11 SpringBoard 0x0001b255 0x0 + 111189\n 12 SpringBoard 0x0001d511 0x0 + 120081\n 13 SpringBoard 0x0000beed 0x0 + 48877\n 14 SpringBoard 0x0000b98d 0x0 + 47501\n 15 UIKit 0x358d85fc -[UIApplication handleEvent:withNewEvent:] + 2268\n 16 UIKit 0x358d7b1c -[UIApplication sendEvent:] + 68\n 17 UIKit 0x358d73b4 _UIApplicationHandleEvent + 6824\n 18 GraphicsServices 0x33e77c88 PurpleEventCallback + 1048\n 19 CoreFoundation 0x3752f5cb __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE1_PERFORM_FU NCTION__ + 28\n 20 CoreFoundation 0x3752f589 __CFRunLoopDoSource1 + 164\n 21 CoreFoundation 0x37521835 __CFRunLoopRun + 580\n 22 CoreFoundation 0x3752150b CFRunLoopRunSpecific + 226\n 23 CoreFoundation 0x37521419 CFRunLoopRunInMode + 60\n 24 GraphicsServices 0x33e76d24 GSEventRunModal + 196\n 25 UIKit 0x3591d57c -[UIApplication _run] + 588\n 26 UIKit 0x3591a558 UIApplicationMain + 972\n 27 SpringBoard 0x00004029 0x0 + 16425\n 28 SpringBoard 0x00003764 0x0 + 14180\n)
    Dec 2 11:41:20 my-iPhone com.apple.SpringBoard[883]: terminate called after throwing an instance of 'NSException'
    Dec 2 11:41:23 my-iPhone ReportCrash[918]: Formulating crash report for process SpringBoard[883]
    Dec 2 11:41:25 my-iPhone com.apple.launchd[1] (com.apple.SpringBoard[883]): (com.apple.SpringBoard) Job appears to have crashed: Abort trap
    Dec 2 11:41:25 my-iPhone UIKitApplication:com.apple.mobilephone[0xee41][898]: Terminating in response to SpringBoard's termination.
    Dec 2 11:41:25 my-iPhone UIKitApplication:com.apple.mobilemail[0xfa74][903]: Terminating in response to SpringBoard's termination.
    Dec 2 11:41:25 my-iPhone UIKitApplication:com.yelp.yelpiphone[0xe3f1][915]: Terminating in response to SpringBoard's termination.
    Dec 2 11:41:27 my-iPhone SpringBoard[919]: MS:Notice: Installing: com.apple.springboard [SpringBoard] (550.52)
    Dec 2 11:41:28 my-iPhone com.apple.SpringBoard[919]: MS:Warning: nil class argument
    Dec 2 11:41:28: --- last message repeated 2 times ---
    Dec 2 11:41:28 my-iPhone com.apple.SpringBoard[919]: MS:Warning: message not found [UIImage defaultDesktopImage]
    Dec 2 11:41:28 my-iPhone com.apple.SpringBoard[919]: MS:Warning: nil class argument
    Dec 2 11:41:28 my-iPhone ReportCrash[918]: Saved crashreport to /var/mobile/Library/Logs/CrashReporter/SpringBoard_2010-12-02-114120_my-iPhone.plist using uid: 0 gid: 0, synthetic_euid: 501 egid: 0
    Dec 2 11:41:28 my-iPhone SpringBoard[919]: MS:Warning: Entering Safe Mode
    Dec 2 11:41:28 my-iPhone SpringBoard[919]: WiFi: Consulting "no-sdio-devices" property.
    Dec 2 11:41:28 my-iPhone SpringBoard[919]: lockdown says the device is: [FactoryActivated], state is 7
    Dec 2 11:41:29 my-iPhone /System/Library/CoreServices/SpringBoard.app/SpringBoard[919]: CLTM: initial thermal level is 0
    Dec 2 11:41:29 my-iPhone /System/Library/CoreServices/SpringBoard.app/SpringBoard[919]: MultitouchHID(222630) uilock state: 1 -> 0
    Dec 2 11:41:29 my-iPhone /usr/libexec/locationd[917]: hidd died. Reestablishing connection.
    Dec 2 11:41:30 my-iPhone itunesstored[922]: MS:Notice: Installing: com.apple.itunesstored [itunesstored] (550.52)
    Dec 2 11:41:37 my-iPhone SpringBoard[919]: WiFi: Consulting "no-sdio-devices" property.
    Dec 2 11:41:37 my-iPhone SpringBoard[919]: WiFi: Joined network xxx WiFi bars visible: NO
    Dec 2 11:41:38 my-iPhone misd[924]: port forwarding is allowed
    Dec 2 11:41:38 my-iPhone misd[924]: checking for carrier provisioning
    Dec 2 11:41:38 my-iPhone misd[924]: carrier service is not available
    Dec 2 11:41:38 my-iPhone misd[924]: published changes: success
    Dec 2 11:41:38 my-iPhone misd[924]: attached to SpringBoard (0x10a4f0, port 0x3f0b)
    Dec 2 11:41:38 my-iPhone misd[924]: detached from SpringBoard (0x10a4f0, port 0x10a530)
    Dec 2 11:41:38 my-iPhone misd[924]: no clients left; resuming idle timer
    Dec 2 11:41:38 my-iPhone SpringBoard[919]: BTM: attaching to BTServer
    Dec 2 11:41:45 my-iPhone kernel[0]: launchd[925] Builtin profile: apsd (sandbox)
    Dec 2 11:41:48 my-iPhone SpringBoard[919]: Could not find mapped image Black_CARRIER_T - MOBILE.png
    Dec 2 11:41:49 my-iPhone SpringBoard[919]: spd:_spd_initialize_communication:112 bootstrap_look_up(): 1102
    Dec 2 11:41:49 my-iPhone SpringBoard[919]: spd:_libspd_initialize_protocol:151 Initializing communication with spd failed
    Dec 2 11:41:49 my-iPhone SpringBoard[919]: spd:spd_register_for_notifications:317 Failure to setup spd registration
    Dec 2 11:41:50 my-iPhone misd[924]: attached to SpringBoard (0x10a250, port 0x3a13)
    Dec 2 11:41:50 my-iPhone misd[924]: detached from SpringBoard (0x10a250, port 0x10a290)
    Dec 2 11:41:50 my-iPhone misd[924]: no clients left; resuming idle timer
    Dec 2 11:41:50 my-iPhone SpringBoard[919]: Received notification that wireless modem state changed. Tethering is now OFF.
    Dec 2 11:41:51 my-iPhone searchd[928]: Opened updates file at /var/mobile/Library/Spotlight/com.apple.MobileSMS/updates.SMSSearch.spotlight
    Dec 2 11:41:54 my-iPhone SpringBoard[919]: spd error: 1
    Dec 2 11:41:54 my-iPhone SpringBoard[919]: BTM: posting notification BluetoothAvailabilityChangedNotification
    Dec 2 11:41:54 my-iPhone itunesstored[930]: MS:Notice: Installing: com.apple.itunesstored [itunesstored] (550.52)
    Dec 2 11:41:57 my-iPhone com.apple.printd[932]: Accepted connection from localhost:631 (Domain)
    Dec 2 11:41:57 my-iPhone com.apple.printd[932]: Closing connection from localhost:631 (Domain)
    Dec 2 11:41:58 my-iPhone SpringBoard[919]: MultitouchHID(222630) uilock state: 0 -> 1
    Dec 2 11:41:58 my-iPhone com.apple.printd[932]: Accepted connection from localhost:631 (Domain)
    Dec 2 11:41:58 my-iPhone com.apple.printd[932]: Closing connection from localhost:631 (Domain)
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    Well, I could be miss informed, but I don't think Pwnage tool support 4.2.1 yet, Redsn0w does, The whole deal with pwnage tool is to unlock using the ipad Baseband (which is a whole mess within itself). That could be your issue.

    As far as your log, I don't see anything weird there but that Spotlight crash when it came back with an error. Not really much to go on.
     
  3. eelpout thread starter macrumors regular

    eelpout

    Joined:
    Oct 30, 2007
    Location:
    Silicon Valley
    #3
    PwnageTool 4.1.3 according to the iPhone Dev Team blog allows for 4.2.1 on a 3G, along with the new Ultrasn0w for unlocking.

    I left my baseband at 5.12.01.

    It's consistently crashing after the "nil class argument" for defaultDesktopImage. The color reference near the top is odd too. I've tried resetting the wallpaper a couple times but that hasn't helped. I guess I'll try and leave a comment for the Dev Team and see if they know anything. I saw another reference to the same kind of crash on a Polish iPhone site.
     
  4. maturola, Dec 2, 2010
    Last edited: Dec 2, 2010

    maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #4
    According to that Blog...

    Anyways, that may or may not be your issue all i wanted to point out is that 4.2.1 JB is pretty much alpha at this moment, and issues like that are common and expected.
     
  5. eelpout thread starter macrumors regular

    eelpout

    Joined:
    Oct 30, 2007
    Location:
    Silicon Valley

Share This Page