Since upgrading to ML, my 2012 Air has distorted audio playback

Discussion in 'OS X Mountain Lion (10.8)' started by ReflexReact, Sep 9, 2012.

  1. ReflexReact macrumors 6502

    Joined:
    Jun 10, 2010
    #1
    Since upgrading to ML, my new 2012 Air has distorted audio when playing movies in MKV (x264). This is really bad with VLC, however it's oddly not quite as bad when using MplayerX.

    I usually / used to plug the machine into my TV via HDMI cable, passing audio to the TV. However, the audio on my movies now sounds so bad that it's not even worth doing.

    I've noticed that during speech, there is minimal distortion (although the audio still sounds like it's mono), however during a loud scene (e.g. an action scene), the distortion just goes crazy.

    I've tried quite a lot of different movie players and all sound terrible to some extent.

    I am new to macs so would appreciate some advice here.

    Thanks,

    RR :cool:
     
  2. ReflexReact thread starter macrumors 6502

    Joined:
    Jun 10, 2010
    #2
    No one got any ideas at all? Sounds like I need to go back to Apple then :(
     
  3. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #3
    It may be a logic board issue, they'll test the logic board and decide. If it is the board, they'll replace it under warranty. If absolutely necessary and audio isn't important to your workflow, they can order the board and call you when it arrives. That way instead of having to have it sent out or in the shop for days, you can get it done right quick.

    It only does it with MKV files when plugged in through thunderbolt? Or does it happen regardless of whether it's connected to the HDTV or not?
     
  4. ReflexReact thread starter macrumors 6502

    Joined:
    Jun 10, 2010
    #4
    Good question - I'll need to check!

    I would have hoped they'd just swap it on the spot given its like 1 month old!
     
  5. ReflexReact thread starter macrumors 6502

    Joined:
    Jun 10, 2010
    #5
    New MBA, same issue. I think it's something to do with Mountain Lion. Either way, I give up on Max OS X - it's rubbish.
     

Share This Page