Single Application Mode

Discussion in 'macOS' started by jkuz, Apr 11, 2012.

  1. jkuz macrumors newbie

    Joined:
    Apr 18, 2011
    #1
    Hey Guys,
    I recently reinstalled Snow Leopard and updated to 6.8
    I like to think of myself as more than a novice user, and I have installed an Snow Leopard before but I am having a very strange issue.

    So I'll paint the picture as follows. I open a forum using Firefox talking about and issue I am working on in Xcode. I want to read the forum with firefox running in the background and have xcode on top so i can read the forum and type in xcode at the same time. This has always been something I could do in Mac osx but currently when I switch applications using cmd+tab it hides all other applications but the one that I have switched to. It is INCREDIBLY frustrating.

    I have done some research into this before posting and I have found that since the original osx release there has been an option called Single-app mode. Which does what what I am describing. I have found a terminal command that should turn this off.
    First I type this line
    defaults write com.apple.dock single-app -bool false
    then
    killall Dock

    Which is what I am supposed to do but it won't work. I have tried this and then restarted my computer and nothing is working. It is incredibly frustrating not to be able to cross reference firefox while coding.

    PLEASE HELP!!!
     
  2. blakekl macrumors newbie

    Joined:
    Apr 9, 2012
    #2
    Doesn't sound like Single-Application mode...

    Single application mode is tied exclusively to the dock. It should only take affect by clicking on the dock, not by using the cmd-tab command...

    My guess is that you may have switched to a different space accidentally. I'm guessing you launched x-code in space 1 and firefox in space 2... Try hitting ctrl-arrow keys to move to your different spaces and see if you find firefox in one and x-code in a different one.
     

Share This Page