Single finder window rather than multiple

Razorhog

macrumors 65816
Original poster
Sep 16, 2006
1,144
116
Arkansas
Hey all, I did a search but couldn't readily find an answer. When browsing with Finder, how do I get it to open new windows in the same window, rather than it opening a new window each time?
Thanks
 

Razorhog

macrumors 65816
Original poster
Sep 16, 2006
1,144
116
Arkansas
When you click on a link in finder, it opens in a new window. I'd like it to open in the current window, like I have windows xp set to do.
example: when I open Mac Harddrive, I click on applications which opens a new window. Then I click on utilities, which opens a new window. Then I launch activity monitor. Then I have to go back and close each individual window that was opened. Make more sense?
 

disconap

macrumors 68000
Oct 29, 2005
1,800
2
Portland, OR
Ok, if it's opening an actual new window, that would be a preference you should change (or you are in OS9). If it's replacing what was there with the new folder, like how a web page would function, then you just need to change the view; Icons, Lists, and Columns are your three choices, Columns is what it sounds like you want (it's command + 3 or click the gui image).
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,208
1,106
It sounds like you have "Always open folders in a new window" checked in Finder preferences. Uncheck that box.
 

Razorhog

macrumors 65816
Original poster
Sep 16, 2006
1,144
116
Arkansas
It sounds like you have "Always open folders in a new window" checked in Finder preferences. Uncheck that box.
The box is unchecked.
When you open Macintosh HD, and then open applications, does it open a new window or stay in the same one? Mine opens a new one...
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,208
1,106
Which Finder view are you using?

Mine opens in the same window (with the preference unchecked) in all three views, but maybe narrowing down what view you're using and if it happens in all views will help.

You may just be able to trash your Finder preferences and see if that fixes it.
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,208
1,106
Okay...try dragging the Finder preference to your Desktop and relaunching Finder. It's at ~/Library/Preferences/com.apple.finder.plist. Just drag that to your Desktop. Then choose Force Quit from the Apple menu and relaunch Finder. You may have to adjust a couple of preferences, but see if that helps.
 

Tel

macrumors regular
Dec 13, 2005
103
0
England
Does your finder window have the sidebar showing? If not, click the pill button in the top right of the window to restore it. The view with no sidebar opens everything in a new window whereas the view with the sidebar opens them in the same window.
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
17,208
1,106
Tel said:
Does your finder window have the sidebar showing? If not, click the pill button in the top right of the window to restore it. The view with no sidebar opens everything in a new window whereas the view with the sidebar opens them in the same window.
Excellent point...I hadn't even considered that possibility. Do you mean that there are people out there who don't use the Sidebar?!? :eek: :D ;)
 

Razorhog

macrumors 65816
Original poster
Sep 16, 2006
1,144
116
Arkansas
Does your finder window have the sidebar showing? If not, click the pill button in the top right of the window to restore it. The view with no sidebar opens everything in a new window whereas the view with the sidebar opens them in the same window.
That's perfect! Works exactly like I want to now and the sidebar is nice! Thanks for helping out a newb. It's little things like this that make the Mac community so cool. :D