Single User Mode Enable Networking

Discussion in 'Mac Basics and Help' started by macaleb, Feb 27, 2015.

  1. macaleb macrumors newbie

    Joined:
    Feb 27, 2015
    #1
    TLDR: How do i enable networking in Single User Mode under 10.6.8

    My Goal is to connect to a local server via an afp share so i can transfer photos from my broken imac. I can only boot in safe mode and single user mode. Ive read that safe mode doesn't allow file transfer over the network so Single User Mode is my only option. (I.E i cant use GUI all i can use is commands.)

    This is the code i use, (which has been proven to work on my macbook)

    mount -t afp afp://Username:password@ipaddress/afpshare /Volumes/Freenas​

    Running this code gives an error 22. After lots of researching and pulling hair i then realized that i cant even ping it :mad:, so i then started looking to enable networking.

    ive tried this sites options in launching daemons but they don't work because there not for 10.6.8

    http://www.westwind.com/reference/os-x/commandline/single-user.html

    ive tried to launch these daemons but they return an endless systemShutdown false error message

    launchctl load /System/Library/LaunchDaemons/com.apple.kextd.plist
    launchctl load /System/Library/LaunchDaemons/com.apple.notifyd.plist
    launchctl load /System/Library/LaunchDaemons/com.apple.configd.plist


    And before you ask
    yes i have ran fsck and it returns ok
    yes i have mounted the drive with mount -uw /
    yes i have tried SystemStarter

    My Question is how can i enable networking so i can mount a server drive

    Thank you so much in advanced.
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    It's not possible in single user mode.
    Why not just copy your files to an attached external drive?
     
  3. macaleb thread starter macrumors newbie

    Joined:
    Feb 27, 2015
    #3
    why wouldn't it work

    well that would explain why im having so much trouble finding an answer online.

    But why wouldn't it work, isn't this what the command line was made for, to backup data while the gui is down?

    and if not what is the correct way backup files to my server?
     
  4. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #4
    Single user mode is not the same as the command line. The command line is always present and available, whether the system is in single user mode or not.

    The reason some features don't work in single user mode is because the services (daemons or other code) that provide those features haven't been started yet. Single user mode is intentionally designed to not start most system services. The system has to get farther in its normal startup sequence before those features become available. The presence of a command line won't magically make those features start working.


    Instead of describing your proposed solution, could you please describe the problem you have, with details?

    For example, exactly what Mac model is exhibiting the problem? All you've mentioned so far is "my broken imac", which tells us nothing about what model it is, what features it has, what the OS version is, etc.

    Please explain exactly why you can't use the GUI. Is it a graphics chip malfunction? A display malfunction (broken screen)? Something else?

    Also please identify your server. Is it a Mac? Something else? What exactly?


    If your "broken imac" has FireWire, have you tried starting it up in Firewire Target Disk mode?
    https://support.apple.com/kb/PH10725?locale=en_US
    http://en.wikipedia.org/wiki/Target_Disk_Mode

    If that works, you then connect it to another Mac using a Firewire cable, and the other Mac will then see your iMac exactly the same as an external Firewire disk drive. You can then do anything to the target Mac's disk, exactly as if you'd pulled the HD out and put it into an external Firewire disk enclosure.

    If nothing else works, then you can pull the HD out and put it in an external enclosure.

    Or instead of an enclosure, you can try a "USB SATA Dock" (search Amazon), which lets you drop any SATA drive (assuming that's what's in your iMac) into the docking station and have it be read or written as an external USB disk drive.
     
  5. macaleb thread starter macrumors newbie

    Joined:
    Feb 27, 2015
    #5
    Thank you for you help and concern for my problem, but as i see now ive inaccurately described my real problem. I came to the forums because i wanted learn more about troubleshooting my mac using Single user mode to connect my server, hence the title of the thread.

    I described my data backup problem because i thought it would help in what daemons i should start. ive read a bit about how people were running specific .plist's for FTP and SSH and i thought maybe there are certain ones for mount_afp but i couldn't seem to find anything on it.

    Ive ran out of time to transfer the photos using my solution and ive already ordered an external hard drive, but i still want to know why i cant enable networking and mount this drive.

    if it helps here are some specs.



    Hardware Overview:

    Model Name: iMac
    Model Identifier: iMac6,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.16 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 3 GB

    System Software Overview:

    System Version: Mac OS X 10.6.8 (10K549)
    Kernel Version: Darwin 10.8.0


    The iMac one day had a graphic glitch and refused to start up again, after basic troubleshooting i took it to a specialist and he said the graphics card was shot and because the Mac is so old they couldn't get any parts for it.

    I have a python script that exports all iphoto events to folders, (if anyone is interested in it http://soniq.org/macsoftware/15749/iphoto-export-all-events-to-folders#axzz3T5v0yWr8 ) This is what i want to run when the drive is mounted.

    btw my server is a home built NAS running "FreeNAS" software, everything is setup correctly and has worked fine for transferring my macbook photos.
     

Share This Page