Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

madog

macrumors 65816
Original poster
Nov 25, 2004
1,273
1
Korova Milkbar
I'm attempting to run the fsck command in single-user mode as part of my random maintenance (cause I'm too lazy to find my Leopard disk), but ran into a slight problem.

When I plug in my USB keyboard for this (otherwise I use BT) the keyboard works fine. As far as I can tell every key works when the system is running, and there is no problem getting into single-user mode at startup. However, the keyboard no longer works once in single-user mode. I can't type anything in or use the stop process command (something like ctrl or alt and Z or X or C, I couldn't remember so I tried them all).

I thought maybe the computer was frozen in single-user mode, but here's the strange thing, it's 'working'. If I unplug my external BT card, some error will report on the screen about the connection, and the same if I plug it in if it wasn't to begin with.


:apple: So basically, I can boot into SU mode, the machine does not crash, but I can't type anything in.

:apple: I don't have another USB keyboard atm, as the one I have is the backup to the BT,

:apple: I do have a USB 2.0 PCI card which I tried with the keyboard plugged into it, as well as directly into the original USB ports,

:apple: I tried unplugging all my peripherals except the PCI card (and keyboard).


Any insight to this would be much appreciated! Thanks,




EDIT: I don't know how, or why, but after attempting it again while using a powered USB hub (before the keyboard was plugged directly into the tower, no hub) I was able to successfully input commands with my keyboard in SU mode. Other than that, the only thing that has changed was a power outage which lead me to reset the PMU on my logic board. Strange and possibly unrelated, but I thought I'd mention it.
 

angelwatt

Moderator emeritus
Aug 16, 2005
7,852
9
USA
System Preferences > Bluetooth > Advanced

There's a check box for "Open Bluetooth Setup Assistant at startup when no device is present." It's possible there's a conflict going on here between the Bluetooth ad USB devices. I would try unchecking the box to see if it improves the situation. No guarantees, but worth a shot.
 

ravemeover

macrumors newbie
Apr 23, 2011
2
0
Has anyone figured out a solution to this problem>? I have a few imacs and i find it is with the ones operating 10.6 or higher, i am using a dell keyboard. it also seems to happen on the late 2009 and early 2010 a1331 imac , it works on the 2008 line of imacs... The signle user starts up when i hold the Windowes key + S at the same time but when it comes time to input text its as if the keyboard no longer works, but if i unplug the keyboard and plug it back in the command prompt sees that.... Any suggestions? I would love to be able to solve this problem. Thank you
 
Last edited:

falconneil

macrumors newbie
Nov 28, 2012
5
3
you need an older keyboard!

Believe it or not the new thin silver keyboards will not allow text entry at the single user window on an older (2007 and earlier I think) Mac. If you have an older white plastic apple keyboard use that. It will work!
 

Bampelito

macrumors newbie
Mar 25, 2019
4
1
The solution is to start the system up normally and open International in System Preference. Under Input Menu, select a new keyboard layout, then select US again. This worked right away for me.

Tested on iMac G3 500Mhz and Apple Keyboard 2007 A1243 Aluminium
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.