"SIP Enabled" Pop up message

Discussion in 'macOS High Sierra (10.13)' started by joshfairweather, Oct 18, 2017.

  1. joshfairweather macrumors member

    Joined:
    Sep 15, 2017
    #1
    Hi guys!

    Recently bought a Mid 2012 2.5GHz MacBook Pro. As soon as I got it, I installed High Sierra, then migrated from my old 2008 MacBook Unibody (which had unsupported Sierra installed) with the migration came all my apps - Adobe CC, Microsoft Office, iMovie, etc. Every time I boot up my Mac, I get the following pop up message:


    SIP Enabled
    SIP is enabled on this system. Running with SIP enabled could cause issues, such as USB not working. To rectify this, please boot into your system's Recovery Partition or your Sierra Installer USB drive, open Terminal, and run the command "csrutil disable".



    Has this got something to do with my old Mac running unsupported software? How do I go about fixing it - is there a file or something somewhere that migrated with my Mac that wants SIP off? As I obviously now have a system that can run High Sierra by default, seeing this disable SIP message is simply annoying!

    Any help would be massively appreciated!!
    --- Post Merged, Oct 18, 2017 ---
    @dosdude1 maybe you'll know?!
     
  2. jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #2
    Try starting up in Safe Mode (power on while pressing the shift key", and see if the message appears.
    If you don't get the message then the problem is something you migrated over and is trying to run on startup.
    A little sleuthing around might help isolate the offending app.
     
  3. joshfairweather thread starter macrumors member

    Joined:
    Sep 15, 2017
    #3
    @jbarley I believe it's because I applied a patch and unsupported software that needed SIP off, dosdude's installation even states that a pop up message will occur if SIP becomes enabled - that's what's happened here, except I no longer need SIP off to run HS. It isn't an app or something that is causing it, it's something to do with the patch I believe as none of my apps or anything are 3rd party etc..
     
  4. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    Pretty sure it's the patch, I don't think Apple will have this kind of warning build into the system. They want us to enable SIP. Also, for a natively supported system, enable SIP won't cause any issue. Most likely because your patch injected some kext for old hardware, those are not signed (e.g. USB driver). Therefore, if you keep SIP enabled, some hardware may stop functioning due to kext can't be loaded.
     
  5. joshfairweather thread starter macrumors member

    Joined:
    Sep 15, 2017
    #5
    @h9826790 Basically what I assumed - something from the patch lying underneath from the migration, that automatically pops up the SIP message. Any idea how to remove?
     
  6. jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #6
    I would do a reinstall, this would overwrite all the system files while still leaving your apps and home folder stuff in place.
    This should correct the problem files.
     
  7. dosdude1 macrumors 68000

    dosdude1

    Joined:
    Feb 16, 2012
    #7
    Run "sudo rm /Library/LaunchAgents/com.dd1.SIPLD.plist" in Terminal, and that will get rid of that popup.
     

Share This Page

6 October 18, 2017