Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

mrbjr

macrumors regular
Original poster
Dec 16, 2017
115
53
Central Cali
My wife uses Siri for everything, but since getting her a XR a few weeks ago whenever she asks Siri to make a call it automatically goes to speaker. If you make a call from contacts it works normally. I never use Siri myself but tried it on my my 11 Pro and same results. Call routing is set for automatic. Seems like it could be a bug. Anyone else experiencing this?
Both phones are on 13.1.2
 

M33-1

macrumors 6502
Jun 15, 2010
284
158
I just noticed this as well. I haven’t tried asking Siri to call someone and then hold the phone up to my ear. They may have given more intelligence to Siri and noted that when you ask to call someone you are not holding the phone by your head and so switches to speaker.
 
  • Like
Reactions: mrbjr

akash.nu

macrumors G4
May 26, 2016
10,095
12,594
I just noticed this as well. I haven’t tried asking Siri to call someone and then hold the phone up to my ear. They may have given more intelligence to Siri and noted that when you ask to call someone you are not holding the phone by your head and so switches to speaker.

I’ve notified this as well great feature. Makes no sense to have to race the phone to your ear after having it down low to speak to it.

This is exactly the reason.

The general use case is that you won’t ask Siri to call someone if you can hold and operate the phone directly, in which case, you’re far from the phone and putting the call through the speaker is the expected behaviour.
 
  • Like
Reactions: sbailey4

DevinNj

macrumors 68000
Apr 27, 2016
1,688
1,423
New Jersey
Yup, it's changed since one of the recent updates, unsure which one, but you used to have to say "Siri call blah, blah, blah on speakerphone" Much better now, in my opinion anyway...
 

mrbjr

macrumors regular
Original poster
Dec 16, 2017
115
53
Central Cali
Yup, it's changed since one of the recent updates, unsure which one, but you used to have to say "Siri call blah, blah, blah on speakerphone" Much better now, in my opinion anyway...

If it is a feature shouldn’t you be able to toggle it on or off?
 
  • Like
Reactions: BasilFawlty

akash.nu

macrumors G4
May 26, 2016
10,095
12,594
If it is a feature shouldn’t you be able to toggle it on or off?

Not necessarily. That just depends on if Apple / the development company wants it to be like that. It’s the same for so many other features.
 
  • Like
Reactions: DevinNj

phgreer

macrumors regular
Jul 18, 2002
200
121
Greenville, SC
Even when I have my ear buds in it insists on going to speaker. I hate that! I much prefer to use my ear buds.
Same here. I will often have my earbuds in while driving. It's actually against the law where I live to have the phone up to my ear or in my hands while driving. I want to have my earbuds in and talk to her for phone calls, directions, etc. it's hard to understand on speaker over the car noise.
 

BasilFawlty

macrumors 6502a
Jun 20, 2009
848
1,437
New Mexico
I think it's a bug and I have reported it to Apple, but here's a fix:
Two possibilities depending on how new/old your iPhone is. On my iPhone XR:

On current iOS (Settings >> Accessibility >> Touch >> Call Audio Routing (Weird place for it, I know)
Once there change the setting from "Automatic" to "Bluetooth Headset" (This works even if you are using a regular plug-in headset.


Hope this helps someone.

UPDATE:

I just updated my phone to iOS 13.2.2 (from 13.2.1) and tried going back to the Automatic setting in "Call Audio Routing" and it "seems" (so far) that they have fixed the issue. I tried making a few calls with Siri with my headphones plugged in and the calls went to my headphones like it should. Haven't tried it while driving yet, but this is a good sign.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.