Siri and geofencing reminders

Discussion in 'iPhone' started by Arafiel, Oct 15, 2011.

  1. Arafiel macrumors newbie

    Joined:
    Oct 7, 2011
    #1
    Has anyone been able to get this to work?

    If I say "remind me to call my parents when I leave work" she writes out "when I leave work, call my parents" with no geofence. If I say "remind me to call my parents" and wait before she asks when to say "when I leave work" it SEEMS to understand, but then says "I'm sorry, I was unable to create that reminder."

    Anyone have more luck or is this just a bug for the time being?
     
  2. Anonymous Freak macrumors 601

    Anonymous Freak

    Joined:
    Dec 12, 2002
    Location:
    Cascadia
    #2
    I have the same problem.

    The issue, as I see it, is that Siri creates "Tasks" on my Exchange server, which don't allow geofencing. What you need is an iCloud "Reminder", which does. Even when I say "remind me to...", it creates a task on my Exchange account, not a reminder. If I manually edit the list the event is in, I can add the geofence, but I can't figure out how to make Siri default to the iCloud Reminders.

    If I completely disable Tasks on my Exchange account, it works. But I don't want to disable Tasks on Exchange, I only want to make iCloud Reminders the default.
     
  3. Tammster macrumors 6502

    Tammster

    Joined:
    Jun 23, 2010
    Location:
    S Florida USA
    #3
    You dont need to disable your exchange account. By making iCloud the default folder for new reminders (you can always add them manually to other folders without Siri), go to Settings-->Mail, contacts, calendars--> and scroll all the way down to the bottom where it says Reminders. Then just change the default list to iCloud.

    Now it works every time. :D
     
  4. Anonymous Freak macrumors 601

    Anonymous Freak

    Joined:
    Dec 12, 2002
    Location:
    Cascadia

Share This Page