iPhone Siri asks for email address when texting

Discussion in 'iOS 8' started by HelveticaNeue, Oct 1, 2014.

  1. HelveticaNeue, Oct 1, 2014
    Last edited: Oct 1, 2014

    HelveticaNeue macrumors 6502a

    HelveticaNeue

    Joined:
    Apr 24, 2010
    #1
    When I ask Siri to "Text Bob and say hello" Siri says "Ok, which email address for Bob". Of course, I don't want to send it to any email address. It should go to his mobile. If I say to use their mobile number, Siri will say there is no mobile number for that contact. Of course if I tell her to call Bob's mobile she has no issue. It is only for texting she has difficulty.

    For some contacts there is no problem, for many there is. If I remove the email address for the contact then Siri doesn't ask and will just send it to their mobile number. But when I re-add the email address the problem reoccurs.

    I tried resetting all settings. And this is an iPhone 6 set up as new.
     
  2. thekb macrumors 6502a

    Joined:
    May 8, 2010
    #2
    I don't say "Text Bob and say hello..." I say "Tell Bob hello ..." and it works well for me.
     
  3. SnowDX macrumors 6502

    Joined:
    Jun 30, 2010
    Location:
    The Great White North
    #3
    This is also what I do.
     
  4. GueroSinFe, Apr 9, 2015
    Last edited: Apr 9, 2015

    GueroSinFe macrumors newbie

    Joined:
    Apr 9, 2015
    #4
    I have a similar issue here.
    Seems like a bug that occurs when the contact has more than one phone number or email.

    Solution: Remove the second phone number and/or second e-mail addr
     

Share This Page