Siri cannot set location based reminder

Discussion in 'iOS 9' started by NavySEAL6, Jan 10, 2016.

  1. NavySEAL6 macrumors 6502a

    Joined:
    Dec 13, 2006
    #1
    Hi all,

    When I ask Siri to make a location based reminder, it says I have to enable that in location settings. I see reminders is set on never, so I switch to while using the app. I try the request again, and I get the same error message, and the setting is back to never again. I can't get the toggle to stick on while using the app.

    Any ideas?
     
  2. Suckfest 9001 macrumors 6502a

    Suckfest 9001

    Joined:
    May 31, 2015
    Location:
    Canada
    #2
    Maybe try setting the location to Always for Reminders?

    AFAIK it needs to set up a geo-fence which constantly needs location (but in a battery-saving way). So yeah.
     
  3. NavySEAL6 thread starter macrumors 6502a

    Joined:
    Dec 13, 2006
    #3
    It doesn't show always as an option, should it be?
     
  4. Suckfest 9001 macrumors 6502a

    Suckfest 9001

    Joined:
    May 31, 2015
    Location:
    Canada
    #4
    Ah, my bad. No, it's just "while using"

    Don't know why it's still giving you that. As long as general location settings are turned on along with Reminders and Siri, it shouldn't really be doing that...
     
  5. ZEEN0j macrumors 6502a

    Joined:
    Sep 29, 2014
    #5
    I remember having the same issue on my iPad. Can't remember what fixed it though. I didn't do anything special. Try a restart.
     
  6. laszlo182 macrumors regular

    Joined:
    Nov 17, 2013
    Location:
    Bratislava, Slovakia
  7. Imac Sam macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #7
    i found that closing all apps, rebooting the phone, then changing the setting in location services, then trying again fixed it.
     
  8. NavySEAL6 thread starter macrumors 6502a

    Joined:
    Dec 13, 2006
    #8
    Still no luck. It's surprising as I feel location reminders are increasingly used by the masses so they really need to fix this.
     
  9. Imac Sam macrumors 6502

    Imac Sam

    Joined:
    Oct 9, 2011
    Location:
    Harrisonburg, Virginia
    #9
    Did you go to Settings>Privacy>location Services>System Services, and make sure Location-Based Alerts is on?
     
  10. NavySEAL6 thread starter macrumors 6502a

    Joined:
    Dec 13, 2006
    #10
    That worked, thank you!
     

Share This Page