Siri Location-based reminders??

Discussion in 'iPhone' started by afousek, Oct 18, 2011.

  1. afousek macrumors member

    Joined:
    Jul 8, 2009
    #1
    I'm still learning Siri.........and so far it's great. Each day I'm getting the hang of it.

    But, for some reason, I cannot get any location-based reminders to work. And yes, I have the location-based setting on.

    If I tell Siri to remind me to feed the dog when I get home, it won't do it. Or, if I tell it to remind me to get milk when I leave work.....nada.

    Anyone else having issues? Is there something else that I'm missing? I've gone into the Siri settings and gave it "my info", etc.

    Thanks.
     
  2. ZBoater macrumors G3

    ZBoater

    Joined:
    Jul 2, 2007
    Location:
    Sunny Florida
    #2
    It works fine for me. Do you actually see the reminder created in your Reminders app?
     
  3. ksoze macrumors regular

    ksoze

    Joined:
    Oct 25, 2009
    #3
    This seems to be the big issue for many as they explore Siri.

    Some tips, although I think it is still not fully baked with this feature:

    Do you have a Contact entry called (nickname) "home" and "work"?
    Do you have Reminders set to iCloud?
    Do you have MS Exchange with reminders set on?

    All of these seem to intertwine to effect the location-based reminders ability to work as expected or hoped, but it has been flaky for me even after messing with these items. It works one minute and then does not know the location the next time I use a similar command.
     
  4. Bossyman macrumors member

    Joined:
    Oct 18, 2011
    #4
    How do u set reminders to iCloud?

    ----------

    Oops found it. :)
     
  5. ksoze macrumors regular

    ksoze

    Joined:
    Oct 25, 2009
    #5
    Did that work?
     
  6. afousek thread starter macrumors member

    Joined:
    Jul 8, 2009
    #6
    Yes, I have "home" and "work" set in my contacts.
    I also have reminders set to iCloud.
    My email account is MS Exchange. Where do I turn reminders on for Exchange?
     
  7. ksoze macrumors regular

    ksoze

    Joined:
    Oct 25, 2009
    #7
    There was a discussion on the Apple tech boards whioch actually recommended turning reminders OFF in MS X. You do that under Mail settings, under your exchange mail account.
     
  8. Slowlo macrumors newbie

    Joined:
    Oct 7, 2011
    #8
    In addition to what others have said, here's something I figured out (unfortunately...):

    When you're at a location that you thought you should get a reminder for, ask Siri 'Where am I?'. I've found that Google Maps is a little off of my actual home location. I had actually noticed that even before Siri, which is what made me suspicious. And sure enough Siri thought my address was one house over from the actual location.
     
  9. pacmantech macrumors member

    Joined:
    Sep 18, 2006
    #9
    I had this exact same problem and the solution was to turn off Reminders on my Exchange account (corporate email). Works like a charm now. Had tried everything else but I didn't think of a possible conflict like that.
     
  10. GLOC macrumors member

    Joined:
    Oct 23, 2009
    #10
    It only works in the US at the moment too :(

    Regards
     
  11. Caliber26 macrumors 68000

    Caliber26

    Joined:
    Sep 25, 2009
    Location:
    Orlando, FL
    #11
    Settings > Mail, Contacts, Calendar...

    ...scroll to the very bottom and (if you're using an Exchange account on your phone) you ought to see something that says "Default List". Make sure you are defaulted to Reminders and not Tasks. After reading this thread last night (towards the end), I saw someone else having the same issue as you. Apparently, Exchange account users' phones automatically default them to Tasks, which are not location-based like Reminders are. Hope this helps!
     
  12. TheNinjaJedi macrumors regular

    TheNinjaJedi

    Joined:
    Jul 16, 2011
    #12
    I wonder why this is.
     
  13. dhumes0524 macrumors newbie

    Joined:
    Oct 26, 2011
    #13
    Fixed

    I can confirm that for myself, turning off Exchange reminders, and turning on iCloud has resolved this issue.
     
  14. nippyjun macrumors 65816

    Joined:
    Jul 26, 2007
    #14
    Hi.
    How do I turn off reminders on my exchange account which is my gmail account. I don't see the option where to turn it off in my iPhone settings.

    Under settings/mail,contacts,calendars when I look at my exchange account it shows that contacts, calendars, and reminders are synced yet when I click on that account there is no toggle for reminders.

    When I scroll to the bottom of mail,contacts, and calendars it shows reminders, sync one month back.

    Any ideas?
     
  15. sirkackletree macrumors newbie

    Joined:
    Oct 29, 2011
    Location:
    Michigan
    #15
    Thank you

    Finally figured out how to get siri to enable my location based reminders. I had no idea i needed to enable icloud reminders but it worked. Thanks guys.
     
  16. sand0s, Feb 8, 2012
    Last edited: Feb 8, 2012

    sand0s macrumors member

    Joined:
    Feb 2, 2010
    #16
    that's the solution... you can have both on at the same time, but it's important to have reminders set as the default account as Caliber26 points out. glad i found this thread because i was tired of setting up tasks that started out as "When I get Home..." but wouldn't remind me of a damn thing when i got there! :D
     
  17. Steven. macrumors regular

    Joined:
    Aug 16, 2009
    #17
    Is this available in the UK yet, or am I doing something wrong?

    "Your calendar service, which keeps track of your reminders, doesn't allow location-based reminders". :confused:
     

Share This Page