Siri not always working

Discussion in 'Apple Watch' started by jef82, Oct 17, 2015.

  1. jef82 macrumors member

    Joined:
    Jun 6, 2011
    #1
    Sometimes, a bit too often if you ask me, Siri won't work on my Apple Watch. There is an error saying that my Watch and iPhone can't make a connection to Siri. But with my phone it works well. The only solution is that I need to reboot my Watch everytime. Anyone else with this problem? Hopefully it will be sorted out by the next software update. I suppose that it's a software problem? But they aren't testing beta's for the watch or do they?
     
  2. Smurphy Gherkin macrumors regular

    Joined:
    Apr 13, 2015
    Location:
    Melbourne, Australia
    #2
    Not having that exact issue, but am having a lot of trouble with Siri. I don't get error messages, I just get either nothing, or "I didn't get that", or a hang on siri screen.

    It worked a lot better on WatchOS 1.01 with my first Watch - which was replaced due to another problem.

    Siri on iOS9/iPhone6S+ however is much improved for me.
     
  3. Kataran macrumors newbie

    Kataran

    Joined:
    Oct 16, 2015
    #3
    You can try to unpair your watch and start over you won't loose any settings as your watch will make an automatic backup. I did this after I updated to 2.0 and it fixed a lot of my call issues and Siri works perfect now
     
  4. jef82 thread starter macrumors member

    Joined:
    Jun 6, 2011
    #4
    I have done this already, and it seems to work but after a week or so it has the same problem again.
     
  5. Javabird macrumors 6502

    Joined:
    Apr 27, 2015
    #5
    Since the Watch update, Siri isn't working for me consistently. I've found the best way is to say "hey Siri" and then give the request right away without pausing. If I say "Hey Siri" and then pause at all, it just quits after a few seconds.
     
  6. Smurphy Gherkin macrumors regular

    Joined:
    Apr 13, 2015
    Location:
    Melbourne, Australia
    #6
    Well damn if a re-pair hasn't sorted things... for now. Grrr.

    Thanks for the tips though...
     

Share This Page