Siri not working at all on my Mac with Sierra Beta 1

Discussion in 'macOS Sierra (10.12)' started by dsr2, Jun 25, 2016.

  1. dsr2 macrumors regular

    dsr2

    Joined:
    Aug 19, 2013
    #1
    Hey. I installed the update to my MacBook Air and it runs really well except for one thing: The icons for Siri are there, but when I go to use it, nothing happens. I checked preferences and Siri is enabled, but I can't get to even open. Any suggestions?
     
  2. throAU macrumors 601

    throAU

    Joined:
    Feb 13, 2012
    Location:
    Perth, Western Australia
    #2
    Suggestion: file a bug report. This is part of the beta experience, and what you should be doing for any bugs you find.
     
  3. dsr2 thread starter macrumors regular

    dsr2

    Joined:
    Aug 19, 2013
  4. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #4
    You should also do us a favor and change your thread title to make it clear that you're talking about beta software. Perhaps change it to "Siri not working at all on my Mac with Sierra Beta 1".

    Right now, we all know what you're talking about. But in a few years, this thread will still be here and it'll be helpful to future searchers if the distinction is clear.
     
  5. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #5
    In Terminal, run killall Siri. This has happened to me, and restarting the Siri process fixes it.
    --- Post Merged, Jun 29, 2016 ---
    A much better title would be "Siri Enabled, but Refusing to Open on MacOS Sierra (Beta)".
     
  6. spoa94 macrumors 6502a

    spoa94

    Joined:
    Oct 12, 2011
    Location:
    New Orleans, LA
    #6
    I need help too. I can get Siri to launch and listen to my voice but it has never been able to give me results on anything. I get this same response every time.
     

    Attached Files:

  7. NYRob94 macrumors member

    NYRob94

    Joined:
    Jan 31, 2009
    Location:
    Long Island
    #7
    I'm having the same issue even after installing beta 2.
     
  8. zizou_online, Jul 8, 2016
    Last edited: Jul 8, 2016

    zizou_online macrumors newbie

    zizou_online

    Joined:
    Jul 10, 2015
    Location:
    Germany
    #8
    Same here
    --- Post Merged, Jul 8, 2016 ---
    Ok ... I changed the language to english in siri settings ... now its working (in english)
     
  9. arkmannj macrumors 65816

    arkmannj

    Joined:
    Oct 1, 2003
    Location:
    UT
    #9
    Same issue here on Public Beta


    Update: Odd fix but if I set Language to English (UK) instead of English (US)
    and the Siri Voice to British (Female) that specific combination works. if I change it to any other combination then Siri stops working.
     
  10. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #10

    Wow this actually works for me as well as I have the same problem as you. If you find a fix for US voices and language please update :)

    I changed back to US language and US voice and it seems to be working.
     
  11. dsr2 thread starter macrumors regular

    dsr2

    Joined:
    Aug 19, 2013
    #11
    Just an update: I reported the bug to Apple and it now seems to be fixed, at least on my Mac.
     
  12. kh26 macrumors newbie

    Joined:
    May 22, 2015
    Location:
    Lincoln, UK
    #12
    I had mine originally set to English (UK) and British (Female). Nothing worked. I changed it to English (Ireland) and it worked. Changed it back to UK and it's working fine now.
     
  13. dsr2 thread starter macrumors regular

    dsr2

    Joined:
    Aug 19, 2013
    #13
    Funny you should mention this. I was having an issue of Siri not working on my apple watch. Realized I had my phone using UK English Siri. When I switched back to US English, Siri worked fine on my watch.
     

Share This Page