Siri not working on 4S. I get voice control...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jonloft, Mar 14, 2012.

  1. jonloft macrumors newbie

    Joined:
    Mar 14, 2012
    #1
    Siri is no longer working on my iPhone 4S. Worked fine for the last few months. When I press the main button, I get voice control instead. I didn't do anything (that I'm aware of) that would have triggered this change. Here's what I have tried so far:

    - Siri no longer appears in settings > general.

    - Siri does appear under settings > restrictions, but the switch is toggled "off" and cannot be moved (it's grayed out).

    - I have done a settings reset from the iPhone

    - I have done a full restore from iTunes (with backup)

    - My keyboard and language are both set to US English

    Help! I've exhausted all similar posts on forums without success. Any iPhone wizards with something new that I can try?

    Thanks!
     
  2. littlehouse, Mar 14, 2012
    Last edited: Mar 14, 2012

    littlehouse macrumors newbie

    Joined:
    Dec 12, 2010
    #2
    Siri isn't activated by default.

    You need to activate it in settings.

    There is an option in pass code settings to turn it off on the lock screen if you don't it can be used when your phone is locked.

    --Find out this answer for you. Hope it helps.
     
  3. jonloft thread starter macrumors newbie

    Joined:
    Mar 14, 2012
    #3
    Siri was already toggled on in the pass code settings. That did not solve the problem. Just to be clear Siri does not work at all now, not just when locked.

    Also, the dictation button is gone from my keyboard in all apps and built in utilities. I assume the problem is related.

    Thanks for the idea but I'm still stuck.
     
  4. akaiito099 macrumors newbie

    Joined:
    Jun 16, 2012
    #4
    Hi,Have you checked the siri-proxy?
    please ensure your spire siri-proxy address is exactly https://74.131.13.153:443 not https://74.131.13.153.443.
    are you connected to a wifi? if not please connect it. then try fixing your settings here Settings>General>Restrictions>Siri>ON. turn it off first then turn it on again. I experienced that before and fixed it by just reading on the internet.

    try to check this site, there are alot of active users who are willing to help

    http://goo.gl/HlGhw
     
  5. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #5
    Have you connected to a corporate mail server or is it a phone provided by your employer? If Siri is turned off in restrictions and the toggle is grayed out it sounds like you have a provisioning profile installed that's forcing it off
     

Share This Page