Siri Not Working When Opened with Headset Remote Button

Discussion in 'iPhone Tips, Help and Troubleshooting' started by thelatinist, Aug 15, 2014.

  1. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #1
    My phone's suddenly developed a problem with Siri. It hears nothing through my headset microphone if and only if Siri is opened using the headset remote button. If I open Siri with the Home button, it hears through the headset mic just fine.

    Everything else about Siri works just fine. There is no problem using my car's bluetooth to invoke Siri. There is also no physical problem with the microphone (I have used multiple known-working headsets, I can record voice memos over the headset mic, and I can even use Siri with the headset mic if I open Siri using the Home button instead of the remote button.

    Might seem like a minor thing, but I ride 10-20 miles on my bicycle every day, so I need to be able to use Siri without access to the phone.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    That sucks man.
    How long ago did it start giving you this problem? And did you install or update any recent JB hacks that might have maybe caused this bug?
     
  3. thelatinist, Aug 16, 2014
    Last edited: Aug 16, 2014

    thelatinist thread starter macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #3
    It started several days ago, perhaps more than a week. At first I assumed it was a problem with my headset, and I only really tried any troubleshooting last night.

    I updated a bunch if things about two weeks ago. I probably should not have; most of the updates were undoubtedly merely compatibility updates with 7.1. I think I shall go through an uninstall things slowly to see if it helps. I really do not want to upgrade to 7.1 and lose my jailbreak. I'm not willing to use Pangu.

    ETA: I just rebooted and disabled MS (which should take out most of my extensions) using volume up. No luck.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Yes, same issues with me in the past.
    I did updates for packages that were mostly effecting compatibility with ios 7.1.2 JB.
    But Im still on 7.0.4
    And then by trying to fix what wasn't broken on my end I got bugs and packages didn't run right.
    Its weird how its still giving you this issue with MS disabled.
    Like you said next step would be to start removing hacks one by one and hope to isolate the incompatibility.
    I'm not a big fan of Pangu either.
     
  5. thelatinist thread starter macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #5
    I suppose I do have some non-MS hacks like f.Lux. Those will be the first things I try to uninstall. If it is a choice between this functionality or flux, though, I will have to choose f.lux, I think.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Can't blame you.
    Flux is one of the top reasons to jb your device.
     

Share This Page