General Siri on CarPlay slow?

Discussion in 'iOS 12' started by StuMcBill, Sep 27, 2018.

  1. StuMcBill macrumors 6502a

    Joined:
    Jul 11, 2011
    Location:
    Aberdeen, Scotland
    #1
    I’ve just upgraded it an Xs, which obviously means iOS 12.

    I’ve been using CarPlay for over a year now with my X on iOS 11 and 12 beta and Siri on CarPlay worked great for selecting music on Apple Music.

    However, this week, and especially today, Siri has been taking AGES to find anything.

    Today while driving home I asked for music (which would normally start playing almost instantly) and instead of Siri confirming and playing the music, she thinks about it and says “one moment” or “let me check on that” or another stalling phrase, and sometimes plays the music, or sometimes doesn’t.

    I’m taking the same route, with the same mobile signal.

    Is anyone else seeing similar behaviour? Is there anything I can do to try and fix it?

    Cheers,
    Stewart
     
  2. justice4all77 macrumors newbie

    justice4all77

    Joined:
    Sep 13, 2018
    #3
    Having a similar issue while connected to Bluetooth. I’ve noticed a car logo over the Siri interface when interacting. She will say, just a min and sometimes say I don’t have mobile data on which is not the case. Hoping it gets fixed in a point update
     
  3. az431 macrumors 65816

    az431

    Joined:
    Sep 13, 2008
    Location:
    Portland, OR
  4. StuMcBill thread starter macrumors 6502a

    Joined:
    Jul 11, 2011
    Location:
    Aberdeen, Scotland
    #5
    Updated to 12.1 beta, see if that makes any difference.
     
  5. StuMcBill thread starter macrumors 6502a

    Joined:
    Jul 11, 2011
    Location:
    Aberdeen, Scotland
    #6
    Seems like it’s just Siri asking for music in general, not just when connected to CarPlay. Hmmm
     
  6. StuMcBill thread starter macrumors 6502a

    Joined:
    Jul 11, 2011
    Location:
    Aberdeen, Scotland
    #7
    Don’t suppose anyone else is seeing this behaviour? It only seems to be when I’m asking Siri for music.

    Before where it took a maximum of 2-3 seconds for Siri to start playing the music, it’s taking up to 15-20 seconds to start playing, both on mobile and Wi-fi data.

    Anyone any ideas? I have tried disabling and reenabling Siri and resetting my settings.

    I’m maybe going to restore my phone and start fresh. Don’t really want to but it’s really frustrating me.
     
  7. Sylon macrumors 68020

    Sylon

    Joined:
    Feb 26, 2012
    Location:
    Michigan/Ohio, USA
    #8
    Mine stopped talking when using Maps. For turn-by-turn directions, it'll mute my music but not say anything. I think it's trying to say it over Bluetooth but can't because Bluetooth is turned off. If I plug in the phone and on the phone go to CarPlay settings, I get a prompt for using CarPlay over Bluetooth or USB only. Selecting USB only does nothing.
     
  8. bbydon macrumors 6502a

    Joined:
    May 18, 2005
    Location:
    ATL
    #9
  9. crdav macrumors member

    crdav

    Joined:
    Sep 13, 2016
    #10
    I’m having this same issue too. Just upgraded to an Xs Max yesterday, and it’s taking ages to do anything related to music. It recognises the command fine, but then doesn’t respond after that.
    Did anyone find a solution?
     
  10. someoneoutthere macrumors regular

    Joined:
    Jul 27, 2014
    Location:
    The Great Lakes State
    #11
    I would try two things: First, you could to a soft-reset and see how it treats you. Second, you might want to make a backup of your iPhone, restore it to factory settings and then restore from that said backup.
    Do you typically have your iPhone plugged in? I have my iPhone connected to CarPlay with the lightning cable and typically it’s a little smoother than using Bluetooth. I have not had any issues with Apple Music, making/receiving phone calls and dictating messages with CarPlay. I have iOS 12.0.1 installed on my iPhone.
    Good luck!
     
  11. markfc macrumors 6502a

    markfc

    Joined:
    Sep 18, 2006
    Location:
    Prestatyn, Wales, UK
    #12
  12. bbydon macrumors 6502a

    Joined:
    May 18, 2005
    Location:
    ATL
    #13
  13. ectospheno macrumors regular

    Joined:
    Sep 19, 2005
  14. StuMcBill thread starter macrumors 6502a

    Joined:
    Jul 11, 2011
    Location:
    Aberdeen, Scotland
    #15
    I've done a "fresh out the box restore" since getting my Xs - made no difference.
     
  15. markfc macrumors 6502a

    markfc

    Joined:
    Sep 18, 2006
    Location:
    Prestatyn, Wales, UK
    #16
    No, didn't make a difference, problem still exists.
    --- Post Merged, Oct 17, 2018 ---
    Doesn't make a difference.
     
  16. StuMcBill thread starter macrumors 6502a

    Joined:
    Jul 11, 2011
    Location:
    Aberdeen, Scotland
    #17
    Even if it did work, it defeats the purpose of Apple Music.
     
  17. trouble747 macrumors 6502

    Joined:
    Jul 30, 2011
    #18
    iPhone XS max here, same problem. First noticed on carplay, but it actually happens any time I attempt to access music through siri over cellular. Additionally, asking siri to play music brings up a prompt to enter my Apple ID password. This will typically loop, repeatedly asking for a password. Changing the password, signing out and back in, hard reset, nothing has fixed it. Can manually play music fine over cellular.
     
  18. crdav macrumors member

    crdav

    Joined:
    Sep 13, 2016
    #19
    Seems to now be working with iOS 12.1 for me at least.
    Edit: although intermittently
     
  19. markfc macrumors 6502a

    markfc

    Joined:
    Sep 18, 2006
    Location:
    Prestatyn, Wales, UK
    #20
    Seems to have resolved itself now without me doing anything...
     

Share This Page

19 September 27, 2018