General Siri on CarPlay slow?

StuMcBill

macrumors 6502a
Original poster
Jul 11, 2011
622
80
Aberdeen, Scotland
I’ve just upgraded it an Xs, which obviously means iOS 12.

I’ve been using CarPlay for over a year now with my X on iOS 11 and 12 beta and Siri on CarPlay worked great for selecting music on Apple Music.

However, this week, and especially today, Siri has been taking AGES to find anything.

Today while driving home I asked for music (which would normally start playing almost instantly) and instead of Siri confirming and playing the music, she thinks about it and says “one moment” or “let me check on that” or another stalling phrase, and sometimes plays the music, or sometimes doesn’t.

I’m taking the same route, with the same mobile signal.

Is anyone else seeing similar behaviour? Is there anything I can do to try and fix it?

Cheers,
Stewart
 
  • Like
Reactions: justice4all77

justice4all77

macrumors member
Sep 13, 2018
38
42
Having a similar issue while connected to Bluetooth. I’ve noticed a car logo over the Siri interface when interacting. She will say, just a min and sometimes say I don’t have mobile data on which is not the case. Hoping it gets fixed in a point update
 

StuMcBill

macrumors 6502a
Original poster
Jul 11, 2011
622
80
Aberdeen, Scotland
Don’t suppose anyone else is seeing this behaviour? It only seems to be when I’m asking Siri for music.

Before where it took a maximum of 2-3 seconds for Siri to start playing the music, it’s taking up to 15-20 seconds to start playing, both on mobile and Wi-fi data.

Anyone any ideas? I have tried disabling and reenabling Siri and resetting my settings.

I’m maybe going to restore my phone and start fresh. Don’t really want to but it’s really frustrating me.
 

Sylon

macrumors 68020
Feb 26, 2012
2,032
80
Michigan/Ohio, USA
Mine stopped talking when using Maps. For turn-by-turn directions, it'll mute my music but not say anything. I think it's trying to say it over Bluetooth but can't because Bluetooth is turned off. If I plug in the phone and on the phone go to CarPlay settings, I get a prompt for using CarPlay over Bluetooth or USB only. Selecting USB only does nothing.
 

crdav

macrumors member
Sep 13, 2016
73
55
I’m having this same issue too. Just upgraded to an Xs Max yesterday, and it’s taking ages to do anything related to music. It recognises the command fine, but then doesn’t respond after that.
Did anyone find a solution?
 

someoneoutthere

macrumors regular
Jul 27, 2014
222
30
The Great Lakes State
I would try two things: First, you could to a soft-reset and see how it treats you. Second, you might want to make a backup of your iPhone, restore it to factory settings and then restore from that said backup.
Do you typically have your iPhone plugged in? I have my iPhone connected to CarPlay with the lightning cable and typically it’s a little smoother than using Bluetooth. I have not had any issues with Apple Music, making/receiving phone calls and dictating messages with CarPlay. I have iOS 12.0.1 installed on my iPhone.
Good luck!
 

trouble747

macrumors 6502
Jul 30, 2011
322
11
iPhone XS max here, same problem. First noticed on carplay, but it actually happens any time I attempt to access music through siri over cellular. Additionally, asking siri to play music brings up a prompt to enter my Apple ID password. This will typically loop, repeatedly asking for a password. Changing the password, signing out and back in, hard reset, nothing has fixed it. Can manually play music fine over cellular.
 

crdav

macrumors member
Sep 13, 2016
73
55
Seems to now be working with iOS 12.1 for me at least.
Edit: although intermittently
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.