Site check please

Discussion in 'Web Design and Development' started by MacBoobsPro, Aug 8, 2008.

  1. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #1
    I have finally done the big update to my site that it so sorely needed but I kept putting it off. Anyhoo... previously I had sporadic reports of it not displaying correctly in Internet Explorer and users couldn't navigate around the site.

    I would be grateful if a few people could spare the time to have a nosy round my site (especially if you have IE) and report back if you find any problems or graphic anomalies.

    The site is built entirely using iWeb. :cool:

    http://www.stuartluff.co.uk

    Thank you

    EDIT: I forgot to mention. If you could also look at the Logobox section too as it is all part of the same site. I appreciate your time, thanks.
     
  2. MentalFabric macrumors 6502

    MentalFabric

    Joined:
    Mar 10, 2004
    #2
    It all looks fine to me! Links work, and the form appears to. congrats!
     
  3. MacBoobsPro thread starter macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #3
    Thanks. Were you using Explorer?
     
  4. seattle macrumors 6502

    Joined:
    May 15, 2007
    #4
    I was unable to add a comment and the get a quote page did not load the form. I am using Safari on my iMac.

    Now the quote page is loading for me.
     
  5. MacBoobsPro thread starter macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #5
    I checked the quote form and it did seem to load albeit slowly. Its hosted over at Wufoo.com so maybe it was just a glitch.

    Regarding the Comments I too cannot add a comment but as this is all done in iWeb and using the built in comment engine from Apple I guess its something their end that is not working. I will look into it.

    Thanks for the info.

    If there are any users with Explorer who have some spare time to kill (its Friday so there should be a lot of skiving) I would be grateful for your input.
     
  6. bsheridan macrumors 6502

    bsheridan

    Joined:
    Jan 11, 2008
    #6
    Using FF3 3.0.1 on OS X 10.5.4.

    Looks all good to me, although the form failed to load the first time but a page refresh sorted that out.

    Just a few niggles;
    • 'View Stuart Luff's Portfolio' does not have a link attached to it.
    • When you click 'Hire Stuart', the hyperlinks for 'get a quote' with the word 'here' change to the same colour of text as the surrounding text after you have already clicked on them before. Perhaps changing them to a different colour and they will still stand out.

    Nice looking site, keep up the good work!
    :)
     
  7. MacBoobsPro thread starter macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #7
    Thanks. I'll check the links!

    EDIT: Excellent spot! I forgot to set the visited colour to red. Nice one. Cheers!
     
  8. seattle macrumors 6502

    Joined:
    May 15, 2007
    #8
    I just tested your site with my PC (XP with IE) and the get a quote page gives me an error "Internet Explorer cannot display the webpage"
     
  9. MacBoobsPro thread starter macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #9
    Freakin IE is a pain in the arse. Its only IE I have problems with, I just wish people would realise how crap it is and stop using it. That way everybody who creates a website wouldnt have to do twice as much work to get their site to display in IE.

    Sorry needed to vent!

    Do you know if IE supports iFrames? I have no idea what an iFrame is but apparently to view the quote form you need to be able to utilise iFrames. Im guessing IE can't do this either?

    Thanks
     
  10. MacBoobsPro thread starter macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #10
    I've sorted the comments problem too. It was to do with .mac and .me. For some reason comments only work when visiting the site via .me and not .mac. I've change the forwarder to .me and it seems to work.

    Thanks for spotting this guys.

    EDIT: Thanks for the test Mr Happy. ;)
     
  11. Ntombi macrumors 68030

    Ntombi

    Joined:
    Jul 1, 2008
    Location:
    Bostonian exiled in SoCal
    #11
    Looking from FF3 on OS 10.4.11


    On the left, "View Stuart Luff's Portfolio" isn't a link, but "Hire Stuart Luff" is.

    You have a typo under "resources," "Logobox" on the home page:
    The plural of logo is logos, not logo's. I know you know that, but that's the typo on the home page.
    You have a typo in the About Logobox page:
    "Theres even an iPhone friendly version" needs an apostrophe.

    What's the point of "Current Project?" It's not a link, it doesn't lead anywhere, and it doesn't tell me anything.


    Otherwise, it looks good. :)
     
  12. MacBoobsPro thread starter macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #12
    Thanks for the critique. 'Current project' will eventually link to info about the project. Also the portfolio pieces will eventually link to further information about each project.
     

Share This Page