Site looks awful in Mac browsers

depiction

macrumors newbie
Original poster
Mar 16, 2005
21
0
I am not experienced with Mac computers, but I have developed a site for my school and it looks great in all of the windows browsers, Firefox, IE, Netscape, etc.
I was able to get on an iMac at school long enough to notice that the site was absolutely useless in IE on the Mac. I'm not sure what version it was. Could someone look at it and see what I can do to get it too look right on a Mac.

I would also appreciate it if someone could make a screenshot for me. I tried to get a screenshot at http://www.danvine.com/icapture/, but the queue was full.

Thanks.

http://www.depiction.net/harding/home
 

depiction

macrumors newbie
Original poster
Mar 16, 2005
21
0
Thanks to both of you. They look a lot better than I thought they would; they are actually usable.

Is there anyone out there that has IE that could provide a screenshot? The computer I was using was a few years old, and is rarely used. Maybe the browser just hasn't been updated.
 
Comment

brap

macrumors 68000
May 10, 2004
1,701
0
Nottingham
Wow, that site actually broke my explorer!

IE5.2 just stopped responding each time I tried to pull up the page, I had to actualy force quit out!
It must be your CSS, because the XHTML is great. Perhas the use of "html > body" is confusing the parser.
 
Comment

RacerX

macrumors 65832
Aug 2, 2004
1,504
2
depiction said:
Is there anyone out there that has IE that could provide a screenshot? The computer I was using was a few years old, and is rarely used. Maybe the browser just hasn't been updated.
A few years old? It most likely has the newest version of IE for Mac then. Microsoft stopped developing IE for Macs back in 2001.

If I were you I wouldn't be working too hard to support that browser, if the page works in Firefox, Netscape and Safari on Macs, your in pretty good shape.
 
Comment

mkrishnan

Moderator emeritus
Jan 9, 2004
29,777
12
Grand Rapids, MI, USA
brap said:
Wow, that site actually broke my explorer!

IE5.2 just stopped responding each time I tried to pull up the page, I had to actualy force quit out!
It must be your CSS, because the XHTML is great. Perhas the use of "html > body" is confusing the parser.
I don't know why I felt compelled to try after the last couple of responses, but it crashed MSIE on my machine too. :( On FF, it looks just like the previously posted FF screenshot above.

Oh, and lol #2, no one posted Safari! Here it is, looks pretty much just like FF.

 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.