Sites folder and weird permissions errors

Discussion in 'macOS' started by JonD25, Nov 13, 2007.

  1. JonD25 macrumors 6502

    Joined:
    Feb 9, 2006
    #1
    I'm running Leopard, upgraded from Tiger, and I thought I'd get my Web Sharing option going. But whenever I try and load the index page for my account's site folder, it tells me I don't have permission to access. I went to Get Info on my sites folder and made sure it was set to give read access to everyone and I have read and write access, and I also applied it to all enclosed items within the folder. But still no go. I even went to the index file and tried to rename it, and it wouldn't let me rename it because I don't have permission to, even though my account does have write access.

    I did notice something weird though. For the file, it says that I have read and write, (unknown) has read only, everyone has read only, but there's also another listing of everyone at the top that has Custom set as it's privilege. If I set that to Read, suddenly I can rename it again. But this second everyone isn't on the Sites folder itself. Also, if I click the little plus sign, Finder crashes. And clicking the minus sign doesn't even do anything.

    So now that I have access to the index page to rename it, I still can't access it through Safari without it giving me a 403 Forbidden. Yes, I repaired permissions. Nothing. Any help?
     
  2. JonD25 thread starter macrumors 6502

    Joined:
    Feb 9, 2006
    #3
    That seems to work for keeping it from crashing when I click the plus, but only until I edit the file and save it (or create a new file). Then the (unknown) group shows up again and clicking the plus crashes it again. I also still am getting the 403 Forbidden when trying to access my sites folder through Safari. I did some of the things in those threads, including changing my group ID to 20.

    I'm starting to realize that doing the upgrade option with Leopard wasn't worth it. I don't know if I should just not even try to fix this since it's so over my head anyways and I don't want to screw things up even more and either wait for 10.5.1 to see if it fixes things or do a clean install now and use Migration Assistant to get things back.

    It doesn't seem to be an imperative issue, since I've been using Leopard for a couple weeks now without noticing anything, but it does seem like an underlying issue that might pose bigger problems in the future. I dunno.
     
  3. JonD25 thread starter macrumors 6502

    Joined:
    Feb 9, 2006
    #4
    I did a lot of stuff with those threads on Apple.com forums, and I'm pretty sure I fixed my permissions problem in regards to Finder crashing on me and the "unknown" username.

    However, I still don't have permission to access my shared sites through Safari.

    Possibly unrelated, my shared folder connection isn't working. My roommate who has Leopard as well tried click on my Mac under "shared" in Finder and connecting, but it won't let him connect. I can connect to his shared folder without problem. And yes, I have file sharing turned on and the permissions for my Shared folder is set correctly (I can read and write, everyone else only read). However, screen sharing seems to work fine. I even turned off the firewall and Little Snitch just in case it was somehow blocking it, but nope.
     
  4. JonD25 thread starter macrumors 6502

    Joined:
    Feb 9, 2006
    #5

Share This Page